My audio is completely messed up

I was trying to remove one output device here and I think I have destroyed my audio. Sometimes the speaker is working fine and stops. Sometimes all the output devices disappear from my list, there are 2 pulse audio volume control in my computer, I want to know if is it possible to solve this problem without reinstalling Manjaro, I am using the computer for work.
Here is my inxi -Fazy results

System:
  Kernel: 5.15.85-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64
    root=UUID=52fa92b3-346f-49d0-8451-85818eabe887 rw rootflags=subvol=@ quiet
    splash apparmor=1 security=apparmor
    resume=UUID=a77cec8e-084c-42b3-a4e9-83bcb4d4d329 udev.log_priority=3
  Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 5402 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0FJYHK v: A00 serial: <superuser required> UEFI: Dell
    v: 1.8.0 date: 10/01/2021
Battery:
  ID-1: BAT0 charge: 45.6 Wh (100.0%) condition: 45.6/53.0 Wh (85.9%)
    volts: 16.6 min: 15.0 model: BYD DELL TXD0316 type: Unknown serial: <filter>
    status: full
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xA6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 12 MiB
    desc: 1x12 MiB
  Speed (MHz): avg: 1620 high: 2198 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1217 2: 1336 3: 1654
    4: 2037 5: 1259 6: 2091 7: 2198 8: 1169 bogomips: 27040
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
    active: HDMI-A-1,eDP-1 empty: DP-1 bus-ID: 0000:00:02.0 chip-ID: 8086:9a49
    class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX330] vendor: Dell driver: nvidia
    v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2022-12) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 bus-ID: 0000:2b:00.0 chip-ID: 10de:1d16 class-ID: 0302
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:4 chip-ID: 0bda:5538 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.org v: 1.21.1.6 with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa dri: iris gpu: i915 display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-size: <missing: xdpyinfo>
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: right model: Samsung SMB2230
    serial: <filter> built: 2011 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: primary,left model: BOE Display 0x082e built: 2018
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel Xe Graphics (TGL GT2)
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound API: ALSA v: k5.15.85-1-MANJARO running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.63 running: no
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IF-ID-1: br-01f3046a5370 state: down mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 3-10:5 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Drives:
  Local Storage: total: 476.94 GiB used: 204.88 GiB (43.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data
    model: IM2P33F3A NVMe 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 92103061 temp: 53.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 75 GiB size: 75 GiB (100.00%) used: 70.43 GiB (93.9%)
    fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 393.44 GiB size: 393.44 GiB (100.00%)
    used: 134.46 GiB (34.2%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 75 GiB size: 75 GiB (100.00%)
    used: 70.43 GiB (93.9%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p2 maj-min: 259:2
Sensors:
  System Temperatures: cpu: N/A mobo: N/A
  Fan Speeds (RPM): cpu: 4569
Info:
  Processes: 382 Uptime: 8m wakeups: 4 Memory: 15.36 GiB used: 6.35 GiB (41.3%)
  Init: systemd v: 252 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: 1429 pm: pacman pkgs: 1419 libs: 318
  tools: gnome-software,pamac pm: flatpak pkgs: 0 pm: snap pkgs: 10 Shell: Zsh
  v: 5.9 running-in: terminator inxi: 3.3.24

Kernel 5.15.84 has broken sound for intel integrated audio, and probably .85 has the same problem. Did you try linux60 (or linux61, which seems to be the new default)? Seems to set it to work again.

1 Like

Ohhh, I will try linux60, thanks!

Had the same issue, changed to kernel linux61, no sound issues any more!

one way in terminal:

mhwd-kernel -i linux61

reboot

remove buggy kernel

mhwd-kernel -r linux515

Good luck!

linux61 will become LTS kernel, so you are as safe as linux515

I tried to change the kernel using GUI (in manjaro settings) and my computer won’t boot, it gets a black screen with a underline on top.

at black screen open a new terminal with ctrl+alt+F2.

then first remove the last installed kernel with

sudo mhwd-kernel -r linux???

reboot to black screen and follow my instructions above, allways start the command with sudo

But i think there are more issues than kernel linux515 only ?!

I found one of the issues, I had 2 pavucontrol different versions installed, so I just deleted one.
I don´t know if there is more problems, I will try to redo with kernel now.

sudo mhwd-kernel -r linux???

If I do this and have any problem I will be able to reinstall it using

mhwd-kernel -i linux61

At the terminal in the boot:?
Thanks!

There are 2 different versions of pavucontrol for different desktop environments:

  • pavucontrol for Gnome, Xfce and other GTK based DEs
  • pavucontrol-qt for KDE and other QT DEs

You don’t need to use -r option with mhwd-kernel to remove a kernel
Use the install option -i to install/reinstall both linux515 and linux61

Kernel v5.15 might have an audio issue but everything else is still working, so it can be retained as a backup option if system cannot boot kernel v6.1

Ctrl+Alt+F2 was not oppening the terminal in the boot black screen but I could see the error

Could not load Kernel Modules
check systemctl status systemd-load-modules.service

I could not check this service cause I could not type any command. I will try to load my manjaro with kernel 4.19 and then try to reinstall 515 after install 61 and try again, but I need to do it later.

i would forget linux515, just install in terminal linux61 that works ok with sound.

For me its the better way installing kernels from terminal with sudo mhwd-kernel -i linux??

In terminal mhwd-kernel tells you for example to update first your Manjaro, GUI kernel install does not tell you such!

So at grub menue choose second line (Advanced?) and there your “old” linux419

To see all available kernels:

mhwd-kernel -l

and to see all installed kernels:

mhwd-kernel -li

1 Like

I am afraid to install just the linux61 and delete the linux515 and will not be able to boot the computer. That’s the reason I am trying to keep the linux515 until make 61 work.

you have nvidia, so add ibt parameter:
sudo nano /etc/default/grub
and inside this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
ibt=off
dont remove anything, just add it to existing parameters, save the file with ctrl+x, update grub:
sudo update-grub
now you should be able to boot with the 61 kernel

@andutra
You probably use a nvidia GPU, that’s the problem to boot linux61.
Very easy to solve: add

ibt=off

to the grub line for booting. And you’ll have a perfect kernel booting, and working audio again.
You probably know how, but just in case: add the code in /etc/default/grub in the GRUB_CMDLINE_LINUX_DEFAULT line and run update-grub

Thanks it worked!
After I change the kernel the sound is working fine, and I don’t know why I have installed the pavucontrol-qt here so I removed it too, now it’s all working good.

1 Like

Data in post #1 shows OP is using PulseAudio; PipeWire service is not running and no mention of JACK

OP probably removed package jack2 for JACK sound server

I don´t have jack2 installed, but I have this pipewires, can I uninstall it?

pipewire-media-session                                                                                                                                                                          [Installed] 1:0.4.1-2                extra 
    Example session manager for PipeWire
pipewire-jack                                                                                                                                                                                   [Installed] 1:0.3.63-1               extra 
    Low-latency audio/video router and processor - JACK support
pipewire-audio                                                                                                                                                                                  [Installed] 1:0.3.63-1               extra 
    Low-latency audio/video router and processor - Audio support
pipewire                                                                                                                                                                                        [Installed] 1:0.3.63-1               extra 

pipewire-jack has jack2 marked as conflicting package, so package manager would have requested user permission to remove jack2 when pipewire-jack was installed

AFAIK pipewire and pipewire-media-session cannot be uninstalled as they are required by Gnome DE

pipewire-audio was released 2 months ago with no comment in release notes or Manjaro release announcements. Arch package changelog has a note ‘split out audio stuff’

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.