My app icons doesn't show or aren't loading

i have a freshly installed manjaro and have only turned it off once. and the next time i open my puter it just doesnt show icons now.
im just a silly little girl and i need help :frowning:

Welcome to the forum!

First thing we need to check is the following…

  • Right-click an empty space on the desktop and choose “Enter Edit Mode” from the menu.
  • Right-click the desktop again and choose “Configure Desktop and Wallpaper”.
  • Check whether Plasma is set to “Desktop” or “Folder View”. You need it to be the latter.
  • Set the folder to view to be your Desktop folder — that’s where your icons live, normally.

If all of the above checks out and it still doesn’t work, then I invite you to come and commiserate with us on the threads below, where you may find a workaround — albeit that it’s a technical one, but the instructions are clear.

:arrow_down:

Long story short, Plasma 5.25.5 sucks and causes a lot of people to lose sleep. The workaround is to replace it with the still maintained Long-Term Support version of Plasma 5.24, which currently stands at version 5.24.7. This does however require creating a local repository on your own computer — again, the instructions are provided for, but more clarification can be added if needed.

The Plasma that’s currently in Manjaro Stable is at version 5.26.2, so we’re inquiring as to whether 5.26 fixes the problems that 5.25 introduced, because if it doesn’t, then we’re going to have to find a way to keep maintaining the 5.24.x LTS packages, given that those packages are no longer officially being offered by Manjaro itself — the reason why can be read in the first of the two threads I’ve listed above.

ok so i tried what you said but still doesnt work, its all icons

also
ok the proglem just got more confusing
so i was playing with display to set my second monitor properly
and then continued watching youtube and then i realize the icons are back
so i think its the display thing
but then i restarted and didnt get the icons again (edited)
and tried the display thing
the icons didnt apear this time

didnt work and how would i go with downgrading it?

First, get the file plasma-5.24.7-LTS.zip from the link below — you only need that one file. :arrow_down:

Normally, the file will be in your ~/Downloads folder, and that is what I’ll be assuming for the following instructions.

Next, open up a terminal window and issue the following commands… :arrow_down:

sudo su -
mkdir /var/cache/pacman/plasma-lts
cd /var/cache/pacman/plasma-lts
mv /home/your-username-here/Downloads/plasma-5.24.7-LTS.zip ./
unzip plasma-5.24.7-LTS.zip
repo-add plasma-lts.db.tar.xz *.zst
rm -f plasma-5.24.7-LTS.zip
cp /etc/pacman.conf /etc/pacman.conf.bak
nano /etc/pacman.conf

You will now have the file /etc/pacman.conf open in nano, which is an easy-to-use editor. Scroll down to where you see a section that has the different repositories listed, i.e. [core], [extra] and [community]. Insert a new section between the [core] and [extra] sections, as follows… :arrow_down:

[core]
Include = /etc/pacman.d/mirrorlist

[plasma-lts]                                # ← new section
Server=file:///var/cache/pacman/plasma-lts  # ← new section
SigLevel = Optional TrustAll                # ← new section

[extra]
Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

Save the file — if you’re not familiar with nano, press Ctrl+O followed by Enter and then exit the editor with Ctrl+X.

Next, log out of Plasma completely — you have to be looking at the SDDM login screen — and switch to a tty with Ctrl+Alt+F2. Log in as yourself and issue the command below to update your system with your local repository. The -Syuu option allows you to downgrade Plasma 5.25.5 to 5.24.7. :arrow_down:

sudo pacman -Syuu

After this, reboot your system… :arrow_down:

sudo systemctl reboot

You should now upon logging in be looking at Plasma 5.24.7. :wink:

2 Likes

im having issues with the unzipping part of all things which is very wiered

"
[LusamineLaptop plasma-lts]# unzip plasma-5.24.7-LTS.zip
bash: unzip: command not found…
"
am i missing a repository or something?
i did everything else as said

Okay, that means you don’t have unzip installed, which is easily remedied… :arrow_down:

sudo pacman -S unzip
1 Like

ok ok
so im a programer and i know a lot of those commands so i know what you were doing in the majority of them and now it works flawlessly
thank you my kind kind human i love you and you make me happy <33333333333

1 Like

ok actually i have another issue with it which is when i got the icons back, i tried restarting it just to be sure it wouldnt disapear again and because it wasnt recognising my seconds screen, it recognized my second screen but the icons are gon again.
i tried repeating the needed parts and realized it wasnt downloading when i was doing ```
sudo pacman -Syuu
because of conflicts so now im confused again on what to do :pensive:

It may just be a timing issue. Maybe give it some more time to load? :thinking:

There was no need to repeat that. You are already running 5.24.7 now.

how do i check which version im using because i feel like it upgraded again after i restarted the computer

Fire up the Info Center — it should be in your application menu. :arrow_down:

oh what the hell its running 5.26.2

That should not have happened — not if you issued -Syuu. :frowning_man:

Are you sure you followed the steps above for adding the local repo? :thinking:

yes
:frowning:

Then I don’t know what went wrong on your end. There was a major update only a few days ago, including 5.26.2, but I had no problem updating my system, and the update process kept me on 5.24.7, as it should have. :man_shrugging:

Hmm… Maybe the fact that you executed -Syuu twice may have something to do with it. You only need to allow downgrading when switching from 5.25.5 to 5.24.7. After that, you simply use -Syu for subsequent updates. :thinking:

It’s also possible that you skipped the repo-add step in my instructions. :thinking:

i might just reinstall because i went to see and the version in my pen drive is 5.21 so i think just not updating it would be safe

oh whats the plan then

That’s old. :astonished:

just confirmed and no i didnt skip that part, is there a way to update to 5.24 instead of 5.25/26 ?