My all external hardrives is read only

Helo im new on Manjaro.i using Linux over 10years,i use Kubuntu before i switch to Manjaro.problem is i know couple comands for kubuntu,but i find on manjaro is little diferend…Now i want copy my files to my external hardive is multimedial hardrive formated to NTSF not FAT32 or another.i got one Western Digital 2Tb and second is same brand only 10TB.Now booth say is read only or if i want create folder is say is inposible to created folder.and if i want change permision setting is impossible.i not use Windows over 12years.since i have many times problems with malwares and viruses on windows xp i desided to go to Linux platform,i start on Ubuntu 9,04and after time come i find more better distribution.KDe is my favorite desktop enviroment.this problem is show couple times,but after some times is not show up.interesting is on Kubuntu if i install system updates,always take very loooong time,over fact i have 32Gb RAM DDR4.but now on Manjaro system updates on total size 1Gb take maybe 30seconds.i have very faster internet connection,but i not understand why on kubuntu was so slow…Next problem:why is this forum half enghlish and menu is in czech language.this is very i switch to english.i really not want see this mixed…thank you.
p.s.:I using this booths ntsf disks on my console xbox series x for recording videos.

Click on your avatar at the top right of the page and click the :bust_in_silhouette: icon. Then select Preferences. You will be taken to your profile page. Click on Interface (at the bottom left).

Interface language

English (US)

Great i change interface language.thank.this problem with read disk only is not always,this happends couple times and i never need changing permision or something like that…in past i have problem with reading my microsd cards.i found is need some like maybe same problem here…maybe.i not rember name,but in name is something FAT32 something…

exFAT? That driver is already included in all recent kernels.

Still, it would be best to ─ as I wrote in the tutorials ─ set up a static mountpoint.

Also you have to make sure that you always safely unmount (eject) the external drives before unplugging them. Not doing so may damage the filesystem, and then the kernel will indeed mount them read-only, so as to prevent further damage.

Yes i doing always by "safetetly removed"option on all my external drives or usb flash drives.but now i look on details on disk and filesystem is different.i cannot post any link or picture…Is possibility for damaging,IF i removed external hardrive after i choose shutdown my system-manjaro on my pc??i think i doit this last time i turned off my pc.and this action is very slow.usuly my pc is imediately shut down…

Is it an ext4 filesystem, perhaps? In that case, the best way is to set up a static mountpoint in your home directory and add a line for the external device in /etc/fstab, because if it’s an ext4 filesystem and it’s mounted under /run/media somewhere, then it is only writable to the root account.

No, if the machine is shut down properly, then that filesystem will have been cleanly unmounted.

It is possible that there is still data in the buffers that needs to be written to the device, and if the device is connected over USB ─ which is a slower bus than SATA or NVMe ─ then it may take a longer time to write the data to the device.

Also, USB sticks are much, much slower than a HDD or an SSD, and so the data remains in the buffer longer. This may also slow down the shutdown of the machine.

i mean shuting down pc was slow,because external hardrive slowing shutdown process.i disconect external drive and pc is imediately power off.

Yes, but that is exactly what I was saying: the machine was still busy writing to your external drive, and because the drive was so slow, it also slowed down the shutdown process.

As a rule of thumb, you should never shut down the machine while it’s writing to the drive. Always wait until it has finished, then unmount the drive, and then shut down the machine.

yes i know.i always finished all processing copying or moving files.

In order to avoid waiting for the writing to finish, you can mount the drive with the sync option, or, as I prefer, you can set a lower threshold for the transfer cache. To achieve the latter, create the following file in /etc/sysctl.d/

[lcoimbra@dg-lcoimbra ~]$ cat /etc/sysctl.d/98-dirty.conf 

The numeric values are bytes, based on the maximum speed of a USB 2.0 pendrive. The system will perform writes every 16MB and will perform synchronized writes if the cache reaches 32MB. This wont slow your system, it will only increase the write frequency, which will also avoid data loss in the case of a crash or a power outage.

By writing more often, progress bars will be better synchronized (more realistic) and you wont have to wait in the end. If you find these values too restrictive, change it to 64MB and 256MB, for example.

EDIT: you need to reboot for the changes to take effect (actually you don’t have to, but I don’t remember how to reload the rules).