Mux switch: How to turn off the discrete GPU after switching on the Optimus, Lenovo Y540

Hello everyone

I have Lenovo Y540 which has an option to turn off intel gpu (Optimus) and 90% of the times I turn off Optimus and use the Nvidia GPU because of the performance difference but I switch on the Optimus when I need the battery life, so here’s the catch:

when Optimus is switched on I get a black screen so I was trying to add a grub option to turn off or blacklist Nvidia GPU when Optimus is turned on but nothing works I still get a black screen, please help.
I don’t want to use windows on battery!

blacklist nvidia

Thank you

Do you have the right drivers? You should have video-hybrid-intel-nvidia-prime drivers

Then you install optimus manager and the GUI to manage the gpu depending what you want,you can with one click in the systray disable the nvidia gpu to save battery.


1 Like

Hello and thank you for the answer.
The problem is if I set it up like this, when i turn off the optimus I’ll get black screen.

The whole point is to use the system with optimus off (like pc) and when on battery turn it on (it is a mux laptop).

The only distro that works is pop os wich after turning on or off sets up itself (something like changing between video hybrid and video nvidia) but after two or three times it breaks and results in black screen.

Now thats weird,do you mean it breaks to the point you cannot enter the OS?
Type this in the terminal and paste the output to give more information about the hardware.

inxi -Fazy
1 Like

Hello everyone and thank you for your replies.

The problem was optimus manager (prime-select) and maybe older than 460 driver!

And the solution was to use nvidia render offloading with 460 driver without those mentioned above and install them with dual graphics and then you can easily switch the iGPU on and off from bios without any broblem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.