Muting LFE channel mutes rear-right channel too (7.1 usb headphone)

Headphone is ASUS H7.

Bass muffles audio, i figured i change the subwoofer (lfe) channel volume.
pactl set-sink-volume 0 50% 50% 50% 50% 50% 40% 50% 50%

Then i notice some sound imbalance.
Test with:
speaker-test -c8 -t wav
Sure enough, LFE and rear-right have the same volume.

Mute it with:
pactl set-sink-volume 0 50% 50% 50% 50% 50% 0% 50% 50%
Test again. LFE and rear-right are quiet.

pactl get-sink-volume 0 dumps:

Volume: front-left: 32768 /  50% / -18,06 dB,   front-right: 32768 /  50% / -18,06 dB,   rear-left: 32768 /  50% / -18,06 dB,   rear-right: 32768 /  50% / -18,06 dB,   front-center: 32768 /  50% / -18,06 dB,   lfe: 0 /   0% / -inf dB,   side-left: 32768 /  50% / -18,06 dB,   side-right: 32768 /  50% / -18,06 dB
        balance 0,00

Seems about right.

So what’s next?
Scuffed hardware/firmware? Pulse issue? Driver issue?
Any input is appreciated.

EDIT: I’m on manjaro xfce.

welcome to Manjaro forum @gxmikvid

Try using numerical values instead of percentage values for setting volume

pactl set-sink-volume 0 32768 32768 32768 32768 32768 0 32768 32768 

If that is not effective, try using the sink name of the sink number
(sink number is more likely to change in PulseAudio if there is more than one sink)
To get sink name:

pactl list sinks short | grep surround | cut -f2

Still mutes the channel.
I have no additional info/solution on my end sadly.

EDIT: muting front-center mutes rear-left, but not vice-versa.

The headphone has a dongle which is just a glorified surround sound card, audio splitter combo with some fancy firmware key for armory 2. PC recognizes as 7.1, sends 7.1 signals, device encodes it to stereo (also splits mic from speaker). Dongle doesn’t do special/specific/magic encoding/decoding that only works with specific software, hence it working on linux and it being recognised as a surround sound capable device.

I got a splitter from my last headphone’s accessories. Headphone can use virtual surround directly from the jack port (tested on windows… heh).

Found this:

More importantly the virtual-surround-sink part. Needs a hrir file.
The ones I’ve found were either 5.1 (i need 7.1) or it just flat out did nothing.
Toss me some hrir sources please.

Also this:

“Generate hrir”
Sub-Question: how? Am i missing something on exactly how to create one?
I assume it creates a generic hrir profile (fine by me) because humans hear differently and different profiles sound better/worse on a person to person basis.

Considering the original problem was too much bass it might be simpler to add an EQ filter (e.g. a high-pass filter, 3-band EQ or graphic equalizer) to deal with that instead of trying to adjust channel levels

The headphone has a dongle which is just a glorified surround sound card

Does the USB dongle have level controls for all surround channels in alsamixer?
Setting channels levels in ALSA might work better than PulseAudio because levels are not all locked together in ALSA

For HRIR files, I assume you have tried the files suggested in module-virtual-surround-sink documentation and other Linux tutorials:

The only other source of HRIR files that I know of is to download Windows application HeSuVi and use hesuvi_convert script to convert HeSuVi presets into a format that can be used with module-virtual-surround-sink

I did try that, it sounded either tinny or unclear.

Yes. It has a master woofer channel but controls are linked as well. Faulty dongle?

As for the rest.

  1. Yes I did try the files.
  2. Didn’t know HeSuVi and its converter existed. Thank you.

I’ll try and report back later.

For future reference and extra reading:
HeSuVi needs a vm (or an actual windows machine), wine won’t cut it.
I got my hands on another dongle, turns out the original was faulty.

So to anyone reading: There are two solutions to this problem. Try them both.
Thx to @nikgnomic for helping.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.