Mute mic keyboard button not working on hp envy x360

I have an hp envy laptop. It has 2 very cool buttons that disable the mic and the camera. The one for the camera works, but the one for the mic does not. It worked on Windows.

This is mi inxi:

inxi -Fxxx                                                       ✔ 
  Host: manjaro Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.2.0 Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell 
  dm: GDM Distro: Manjaro Linux 
  Type: Convertible System: HP product: HP ENVY x360 Convertible 13-ay0xxx 
  v: Type1ProductConfigId serial: <superuser required> Chassis: type: 31 
  serial: <superuser required> 
  Mobo: HP model: 876E v: 12.38 serial: <superuser required> UEFI: Insyde 
  v: F.13 date: 09/09/2020 
  ID-1: BAT1 charge: 25.9 Wh condition: 45.5/51.0 Wh (89%) volts: 11.5/11.6 
  model: Hewlett-Packard PABAS0241231 type: Li-ion serial: 41167 
  status: Discharging 
  Device-1: hid-0018:04F3:2AF4.0002-battery model: ELAN2514:00 04F3:2AF4 
  serial: N/A charge: N/A status: N/A 
  Info: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 
  type: MCP arch: Zen 2 rev: 1 L2 cache: 4 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 31959 
  Speed: 1460 MHz min/max: 1400/2000 MHz boost: enabled Core speeds (MHz): 
  1: 1460 2: 1393 3: 1361 4: 1341 5: 1266 6: 2360 7: 2430 8: 1280 
  Device-1: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel 
  bus ID: 04:00.0 chip ID: 1002:1636 
  Display: x11 server: 1.20.10 compositor: gnome-shell 
  driver: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.10.2-2-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.3.1 direct render: Yes 
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 04:00.1 chip ID: 1002:1637 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Hewlett-Packard driver: snd_rn_pci_acp3x v: kernel bus ID: 04:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtw_8822ce v: N/A port: 2000 
  bus ID: 01:00.0 chip ID: 10ec:c822 
  IF: wlo1 state: up mac: d8:c0:a6:31:4a:c7 
  Local Storage: total: 476.94 GiB used: 145.09 GiB (30.4%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN520 SDAPNUW-512G-1006 size: 476.94 GiB speed: 15.8 Gb/s 
  lanes: 2 serial: 20084C803847 rev: 20120006 temp: 35.9 C 
  ID-1: / size: 451.82 GiB used: 145.09 GiB (32.1%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-1: swap-1 type: partition size: 16.6 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 45.2 C mobo: 20.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 375 Uptime: 1h 54m wakeups: 20382 Memory: 15.09 GiB 
  used: 4.99 GiB (33.0%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.0 Packages: 1589 pacman: 1573 flatpak: 6 snap: 10 Shell: Zsh 
  v: 5.8 running in: gnome-terminal inxi: 3.2.01 

Can you please help me make it work again?

Is that the (fn+F8) key?

1 Like

Yes it is

OK, I have an HP Elitebook G1 that has the same mic button, this is how I fixed it. You have to add a custom mapping udev rule.

From Terminal:
sudo nano /etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb

Add the following;
KEYBOARD_KEY_81=f20 #Fn+F8 on x360, map to F20

Save the file by running:
Ctrl + o
Ctrl + x

Then update your hardware with these commands and reboot:
sudo systemd-hwdb update
sudo udevadm trigger

I got this from an Arch wiki when I was setting up my laptop… works for mine. If it doesn’t just remove the file and run update commands to remove.

1 Like

Unfortunetly it didnt do anything :slightly_frowning_face:
So I should delete that file I created and run:

sudo systemd-hwdb update
sudo udevadm trigger

again and reboot?

Yes remove file and update before moving on.

I found the link, this is where I got my notes: HP EliteBook 840 G1 - ArchWiki

Btw thats the output I get for that update (I still haven’t deleted this file).:

sudo systemd-hwdb update                                         ✔ 

[sudo] password for john: 
/etc/udev/hwdb.d/61-hp-mic-mute-hotkey.hwdb:2: Property expected, ignoring record with no properties.

maybe something is wrong here?

Can you post the contents of the file as you have it now?


On my notes on the second line after …81=f20, I have no space between #Fn +F8, but on the wiki it does, maybe that makes a difference, on my laptop it does have the space.

Okay I added the space, were gonna see in a second

It also did nothing. And I got the same info about it ignoring it bla bla bla. :confused: What now?

I had changed the EliteBook name to x360 thinking it was just a label… but maybe try it exactly as it is on the wiki? Can’t hurt.

But now that Im looking at the wiki
Shouldnt there be a space after #?

Yes, my bad, that is what I meant.

That also didnt do anything :confused:

I just realized that you are running Gnome, are you using Wayland, because that may be why it is not working. My System is Cinnamon Desktop which uses X.

I think its turned off

That’s as far as I can go… the issue is surely a key binding and F8 is F20…Web search time.

Solution here :smiley: :smiley: How to map fn+F8 to F20 key so that mic muting works (hp envy x360)? - #30 by pobrn

1 Like