Mute button LED not lighting

I have an HP Laptop 15-dw3xxx with a Realtek ALC236 sound card. I ran alsamixer but it doesn’t show the “Mute LED” option. Any help will be appreciated.

Read from this point on and the linked articles and responses

I read that wiki but the fix didn’t work.

The mute LED on HP laptops usually does not work without a kernel patch

Bugzilla currently has 16 open bug reports for HP Mute LED issues. But none of those reports have the same audio device. This audio codec is only used on HP models 250 G8, 15-dw3xxx and 15s-du3xxx
Intel Tiger Lake-LP Smart Sound Technology Audio Controller

Archwiki does not have a page for any of these model numbers, but pages for similar models suggest using this modprobe option for the mute LED

sudo tee /etc/modprobe.d/hp-led.conf 'options snd-hda-intel model=hp-led-gpio'

If you tried any other model options suggested in the previous forum post, make sure they are removed before rebooting

If that does not work:

  1. get a full ALSA diagnostic with the model option: sudo --upload

  2. delete the model option: sudo rm /etc/modprobe.d/hp-led.conf

  3. reboot

  4. get another ALSA diagnostic without the model option: sudo --upload

If you post links to the ALSA data here, someone might be able to spot where the problem is
and find a quick workaround or solution

If you create a bugzilla report and attach both diagnostics, ALSA developers will know what to look for and how to fix it, but it might take a while for it to get any attention

For clarity, does the command you asked me to run append options snd-hda-intel model=hp-led-gpio to /etc/modprobe.d/hp-led.conf ?

Assuming what I said above is true… The log before I deleted /etc/modprobe.d/hp-led.conf is at
and the log after I deleted it and rebooted is at

I tried with the newest kernel (Linux 5.19rc7-1) but it still didn’t work. Previously, I was using Linux 5.18.12-3 as my kernel.