Must've done something wrong: after installing video drivers cannot boot

I’ve been using Manjaro KDE for about a year on an old HP G71 Notebook without issue. It even works on a second screen smoothly. I installed the same version of Manjaro KDE on an HP EliteDesk with an Intel 630 video card and it appeared to be functioning okay but I couldn’t get the screen to match that displayed when connected to the laptop. The clarity and colors were off. I tried installing the other drivers listed in the Manjaro Settings Manager under display controller–the video-modesetting and video-vesa and rebooted but now the machine doesn’t get past the line that states `/dev/sda2:clean …'. It just sits there with a flashing underscore.

Is there anything I can do to undo what I just did or do I need to start over and reinstall?

Thank you.

Chroot via live iso and undo it with mhwd.

mhwd --help

Thanks. However, it does the same thing when trying to boot from the live iso. I set the boot options to have USB only checked as I did to install it and the flash drive lights up; so I assume it is attempting to load from the iso. Does that sound accurate?

Live iso has nothing to do with your system, so it should work just the same as before. Unless your gpu died or something.

you can in the stuck screen enter TTY: ctrl+alt+f2 - or f1-f6 keys, enter your username/password, and uninstall the drivers:
sudo mhwd -r pci video-vesa
sudo mhwd -r pci video-modesetting
systemctl reboot

1 Like

Thanks. That makes sense, of course, because Windows 10 was on the machine when I used the live iso to install Manjaro. Nonetheless, nothing I tried (and there are very few options) would boot from the USB or it was booting from the USB and still stopping at the same point.

I was able to boot from CD and restore Windows 10 from a backup disc and USB I made this morning before installing Manjaro. And the display appears much more crisp. I must need a different driver to get it right in Manjaro.

Thanks. I remember that for when I try this again.

I’ve since learned what i was doing wrong and you’re right, of course. It wasn’t booting from the USB.

1 Like