Music stops when locking screen (no background playing)

Happy New Year for all the Manjaro Community out there!! :love_you_gesture: :wink:

Because the Newbie Category is no more available , as well I din´t find anything in the earlear topics ( the closest was this, but no help) to solve my following problem, I have following question and request for support:

While working in Manjaro, I always like to leave my Music playing on VLC or Radiostream in the Browser. But when I leave the PC and I have to lock my Screen, unfortunately the music stops! I only lock it and when I come back and unlock it, starts playing again.I Lock It, not switching to another user!!
I thing this is not quite normal, right?
Is there maybe a setup or configuration that I am missing? Can I fix this, so music can play in the background even if the screen is locked? Or this is something standard and intentionally developed by the Core Manjaro Team?
It is OK if technically not possible, I have no problem with it, I just what to know my options here.

I am running following XFCE Version:

Thank you in advance. I appreciate it.
Sincerely

just install xscreensaver and remove the default one

Hi. I don´t even a screensaver installed at all!

this will work:

sudo vim /usr/bin/xflock4 

comment out this line (put a # before the line):

LOCK_CMD=$(xfconf-query -c xfce4-session -p /general/LockCommand)

now install xscreensaver:

sudo pacman -S xscreensaver 

open the screensaver app from the launcher. it will prompt you to enable the service so click yes and listen to music :wink:

1 Like

Hi

Ok. Thank you for the tipp. But how do I edith the outcome, so I can add # to the required line? There must be a way to edith this outcome.

i hope you mean that you are not able to edit the file using vim (a text editor). you can use nano in that case that case.

sudo nano /usr/bin/xflock4

put a # before the specified line, press Ctrl+X and press Y to save and exit nano. then follow previous instructions.

Hi again.
I appreciate you help and effort. Sorry for the inconvenience but I am still learning.
Your support here just added another chapter to my "Learning to use Manjaro ".

I followed your steps. It seem to work. I edited the line with adding the “#”, thank installed the xscreensaver. I started the application, but didn´t prompt my any service to enable :face_with_raised_eyebrow: I only activated some “daemon”.

So I am not sure if I did everything 100% right, but I locked my screen, and the music was playing in the background. The Login screen is displaying (screensaver in the background), adding my password again and I am logged back in , without interrupting the music play.
So seems to be fine. Hope everything stays this way after the reboot to.
Thank you again. I appreciate your help very much. :ok_hand: :+1:t2:

Best regards

1 Like

yes daemon is a service process that runs in the background.

:partying_face:

it will be fine after reboot. Happy new year!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.