Multiple problems with Steam games

I am extremely new to Manjaro and have zero experience with it. I also really have no knowledge about computers, so please bear with me. Trying to find a fix for 3 problems I’m having with Steam.

  1. Games silently crashing, I’ve seen some forum topics with this but I cannot comprehend how to fix it. It will launch and without any errors or popups, will crash and show it is not running anymore. Most of my games either do this or the second crash.

  2. What seems to be a unity problem that I can only find Windows fixes for: a red exclamation error when launching a game, and then crashes and stops running.

  3. Specifically for a game like Bioshock Remastered that I was given as a gift, it will get to the Bioshock loading page but the game wont actually load, as it freezes my computer, causing me to have to restart the computer itself. Looking for any ways to make it run faster or just anyway for me to actually get to play the game.

NOTES: I have tried deleting and reinstalling Steam, as well as verifying the integrity of the games. None of those fixes worked。

Here’s some info if you need:

  Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=bb64b099-53da-4364-a9e2-20cb8e551695 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Latitude E5510 v: 0001
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 023HKR v: A00 serial: <superuser required> UEFI: Dell
    v: A09 date: 01/28/2011
  ID-1: BAT0 charge: 19.8 Wh (61.3%) condition: 32.3/57.7 Wh (56.0%)
    volts: 11.1 min: 11.1 model: Samsung SDI DELL RM6614B type: Li-ion
    serial: <filter> status: discharging
  RAM: total: 3.63 GiB used: 2.87 GiB (79.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i3 M 380 bits: 64 type: MT MCP arch: Westmere
    gen: core 1 level: v2 built: 2010-11 process: Intel 32nm family: 6
    model-id: 0x25 (37) stepping: 5 microcode: 0x7
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2026 high: 2474 min/max: 933/2533 scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 2369 2: 931 3: 2474
    4: 2332 bogomips: 20220
  Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts ept est
    flexpriority flush_l1d fpu fxsr ht ibpb ibrs lahf_lm lm mca mce mmx
    monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pdcm pebs pge pni
    popcnt pse pse36 pti rdtscp rep_good sep ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc vme vmx vnmi vpid xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Core Processor Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-5.75 process: Intel 45nm built: 2010 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0046 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: LG Display 0x024b built: 2010 res: 1366x768 hz: 60
    dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
    class-ID: 0403
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter vendor: Dell
    Inspiron M5010 / XPS 8300 driver: bcma-pci-bridge v: N/A modules: bcma
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:4727
    class-ID: 0280
  Device-2: Broadcom NetXtreme BCM5761e Gigabit Ethernet PCIe vendor: Dell
    driver: tg3 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A
    bus-ID: 0b:00.0 chip-ID: 14e4:1680 class-ID: 0200
  IF: enp11s0 state: down mac: <filter>
  IF-ID-1: wlp2s0b1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 223.57 GiB used: 92.67 GiB (41.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDA240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 80RL scheme: GPT
  Optical-1: /dev/sr0 vendor: TSSTcorp model: DVD+-RW TS-L633J rev: D200
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 223.27 GiB size: 218.71 GiB (97.96%)
    used: 92.67 GiB (42.4%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: bb64b099-53da-4364-a9e2-20cb8e551695
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 8E9E-9786
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900
  Device-1: 2-1.3:3 info: MosArt 2.4G Keyboard Mouse type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA
    chip-ID: 062a:5918 class-ID: 0301
  System Temperatures: cpu: 51.0 C mobo: N/A sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 2999
  Processes: 235 Uptime: 1h 36m wakeups: 2 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: 1303 pm: pacman pkgs: 1285 libs: 428 tools: pamac pm: flatpak
  pkgs: 0 pm: snap pkgs: 18 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.25

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

This is almost certainly one of your problems. There just isn’t enough memory. Easiest thing to do is create a swap file (check the manjaro wiki for instructions).


I’m not sure that is what’s causing the crashes though. I’ve heard it’s due to some files, but haven’t gotten any advice on it.

I’ll check that out though, if I can figure it out. Thanks!

Is this the correct place to look?

The SWAP is obviously a good lead, just add a swap file, follow the WIKI.

However, are you trying to play Windows games (so with the translation layer called Proton/WINE), on your antiquated hardware?

For example, Bioshock Remastered minimal configuration from Steam page says at least a GTX 670. Do you see the gap there is between the minimum hardware and yours? Also you’ll definitely miss features regarding Vulkan, or the Windows/Proton games.

You only have an integrated chip from your processor, for the video card, and your processor is 10 years old. You may be lucky and able to start a few low end games, but that’s about it. Don’t expect anything to work for the Windows games ran through Proton, it can not work.

//EDIT: maybe you can force the use of WINED3D instead of DXVK to be able to run some of these Windows games with OpenGL instead of Vulkan, but I’m pretty confident Proton is just out of the equation for you with that hardware.


Yeah, I realize alot of the problems are most likely due to how old the computer is itself. However, most of the crashes I’m experiencing (from what I’ve read online) are not due to that, looks to be some sort of file causing it. Obviously I’m not an expert though, so I don’t know.

Yes, I am running Proton for these games. I’m very much not a computer person or a Linux person in general so I don’t know how much of this works.

I am still trying to get the swap file done, but again I’m not a computer person and although it’s rather straightforward on the wiki, I am not fully understanding how to go about doing that.

I’ll try that OpenGL, if I can figure out how to get it work :joy: .

Thanks! It’s been very frustrating recently.

EDIT: I have been running the configuration or whatever through Proton Experimental, not Wine.

If you want to add a SWAP file it is simple, as the wiki says, open a terminal and do

sudo dd if=/dev/zero of=/swapfile bs=1M count=4096 status=progress
sudo chmod 600 /swapfile
sudo mkswap /swapfile
sudo swapon /swapfile
sudo bash -c "echo /swapfile none swap defaults 0 0 >> /etc/fstab"

WARNING: do not mess any line, especially most importantly, the last command, as it will add a line to an important system file (we can fix it easily if you can still access a web browser afterwards, but just do it right the first time).

After that you reboot, you can now see you have a 4GB SWAP and you didn’t break the computer.

For Proton games, in Steam you right click them, go to Properties, and then in the text area for Startup Options, you put PROTON_USE_WINED3D=1 %command% in that text area (to force the use of the OpenGL based translation layer, instead of the Vulkan based translation layer).

Random things you can try:

  • use a different/older Proton version than the one set globally in Seam Settings (right click the game, Properties, Compatibility, check the box and select a different version)
  • delete the Proton prefix for the specific game (go to folder ~/.local/share/Steam/steamapps/compatdata/ and delete/rename the folder named as the game AppID (you can know the AppID of your Steam games by looking at the URL in the Steam Store, or using websites like ProtonDB, SteamDB, or the like, by searching your game and reading its AppID in the provided info). Note that deleting the prefix may/will delete all savegames in it, Most of the time, Steam has Steam Cloud feature for savegames, but some games don’t use that and only do local saves so make sure you do not permanently delete a save file in the process).
1 Like

Maybe the way I fixed my own install will help.

1 Like

Thank you!! I will try those and let you know if it works!!

Edit: I ran the swap file commands and looks like everything is fine. Is there anything else I need to do regarding the swap file?

Thank you!! I will also try that if the previous fix doesn’t work.

I think the Startup Options solved the problem for most of my games. However, Bioshock was loading faster than normal (on the main game loading page) and then randomly just stopped. Not sure if it’s because of what you mentioned before. Usually it freezes up my entire computer, but it seemed to be loading just fine.

Pretty sure I had the compatibility tool off, maybe that’s the reason?

Edit regarding Bioshock: No compatibility tool doesnt seem to be the reason. It looks like it loads fine and pops out another window right as it loads, then stops.

Additional Edit: Looks like there was an error that could be fixed in another game. Wondering if anyone can teach me how to fix it.
Details: Failed to initialize graphics.
Make sure you have DirectX 11 installed, have up to date
drivers for your graphics card and have not disabled
3D acceleration in display settings.
InitializeEngineGraphics failed

The SWAP file probably fixed lot of issues with your computer (in general), you have very limited RAM amount, and most likely what was happening was your RAM being fully filed which then locks/freeze the computer when it doesn’t crash the application trying to use “too much” RAM. the SWAP allows for some breathing room when RAM is full, it ‘unloads’ some data from the RAM to the disk (into the SWAP file), to be able to accommodate for applications requiring more RAM.

No you didn’t have it off, all Windows games in your Steam library use the “compatibility tool”, which is Proton, just by default in the game properties the box is not ticked (you tick it to force the use of Proton when the game has a LINUX version, but basically on most games it is just to change the Proton version used).
The proton version is set globally in Steam Settings (you tick the boxes in Steam Play, and select the version you want to use by default globally).

To me it sounds like your GPU can’t handle what it is asked to do. As said the Proton/WINE compatibility tool requires modern hardware with modern features, to be able to handle Windows games in Steam for Linux. You may have some LUCK with some games, but globally I wouldn’t invest too much time trying to have it to work, especially on recent triple A games.

Alright, thanks!!