Multiple applications (gnome-terminal, timeshift, terminator, etc) won't start after system update

Hey peeps,
I was updating my system and halfway through it I forgot that it was ongoing and shut down my system. After this I was not able to boot and got the error

Error loading \vmlinuz-linux: not found

I was able to fix this error by live booting and then installing a kernel through chroot

but when I boot into my system I get the error -
[FAILED] Failed to start Service for snap application ApplicationName

After I login into the system, when I try to run terminal directly it just buffers and never opens up
when I run gnome-terminal or timeshift through alacritty I get the error -
gnome-terminal: error while loading shared libraries: /usr/lib/ file too short

and when I run terminatot I get the error -

(terminator:5951): Gtk-WARNING **: 21:52:57.915: Locale not supported by C library.
	Using the fallback 'C' locale.
Traceback (most recent call last):
  File "/usr/lib/python3.11/site-packages/gi/", line 139, in create_module
    introspection_module = get_introspection_module(namespace)
  File "/usr/lib/python3.11/site-packages/gi/", line 263, in get_introspection_module
    module = IntrospectionModule(namespace, version)
  File "/usr/lib/python3.11/site-packages/gi/", line 110, in __init__
    repository.require(namespace, version)
gi.RepositoryError: Failed to load typelib file '/usr/lib/girepository-1.0/Vte-2.91.typelib' for namespace 'Vte': The specified typelib length 0 is too short

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/terminator", line 48, in <module>
    import terminatorlib.optionparse
  File "/usr/lib/python3.11/site-packages/terminatorlib/", line 22, in <module>
    from terminatorlib.terminator import Terminator
  File "/usr/lib/python3.11/site-packages/terminatorlib/", line 9, in <module>
    from gi.repository import Gtk, Gdk, Vte
  File "/usr/lib/python3.11/site-packages/gi/", line 141, in create_module
    raise ImportError(e)
ImportError: Failed to load typelib file '/usr/lib/girepository-1.0/Vte-2.91.typelib' for namespace 'Vte': The specified typelib length 0 is too short

I have looked at other threads
and did the following so far -
sudo pacman-mirrors -f 5
sudo pacman -Syyu

sudo nano /etc/locale.gen # uncommented en_US.UTF-8 UTF-8
sudo locale-gen

I have also tried booting the system with multiple different kernel versions -
Linux 6.4.6
Linux 5.4
Linux 4.19
Linux 5.1

This also did not solve the issue.


Tried doing this
Didn’t help
Upon booting I still get the same errors

Other options to troubleshoot

→ Do not proceed past the initial greeter session
→ Switch to a TTY (the physical console)
→ then login
→ from there you should be able to sync the dysfunctional system.

If you cannot get to a TTY
→ reboot
→ access the grub menu (pressing Shift or Esc)
→ edit the grub entry and append the number three (3) to the end of the kernel argument list
→ press F10 to boot the entry.

If that doesn’t work out
→ use a live boot
→ repair your system.

A bonus information: using different kernels are not :magic_wand: when the system is missing files for a given app to function.

1 Like

Okay so I was able to fix the error by the following steps -

Note - you may lose settings for a few applications, I lost settings for MySQL and had to restore database from other backup device so make sure you have backed up everything and the only proceed

  1. Took a backup of the entire home directory with Déjà Dup on an extrenal drive and also using
    pacman -Qqe > pkglist.txt
    I got the list of all the packages that are installed
  2. Live booted manjaro
  3. Re-Installed manjaro entirely on the same disk as earlier
  4. Reboot system after installation
  5. Open Déjà Dup and restore your system from the external drive
  6. Reinstall packages manually
  7. For most of the packages the settings were preserved

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.