Multi-partition images not mounting at manjaro desktop

Hi there,
I’ve got a very ‘odd’ issue where my Manjaro install (on my main pc) isn’t reading all USB/SD drives, just some… Examples that don’t work are for instance, certain Retro-pie images I’d normally write to a usb or sd card. Or Raspberry Pi linux distros. Putting the USB/SD does nothing. But if I format the drives regularly, like exFAT or etc they work fine.
I tried on my Laptop Manjaro, no issues… loads the seperate partitions, they come up etc. But on my main pc, nothing. regular standard drives, with ntfs or fat will mount just fine.

I know I could fix this by simply re-installing my OS but I’d rather not because I’ve had this installation for a couple of years now and it’s setup just right for me.

Hope someone has an idea for me to try, thank you.

What is the filesystem on these drives ?

Maybe you only need to install some drivers. (Gparted may tell you.)

Is this an image with a custom boot loader in front ?
Is there eventually no classical partition table like GPT or mbr ?
Is this a raw filesystem (without partition table) ?

In these cases you may have to search for special tools used in creating these images.

The file systems would be ext4 right? Being Linux for Pi images. The common thing that stops them mounting is usually to do with multiple partitions, or non-standard partitioning schemes. Gparted just says ‘no filesystem on device’.

FYI the topic has been changed to retropie / raspberry pi etc. This isn’t the case. They were just good examples. I have multiple partition images that don’t mount which aren’t those things also.

Does anyone have any suggestions where I can monitor what happens when I insert a drive? Can I at least find an error? Thanks

So what you are saying is that these devices are recognized, and even mountable when formatted properly, but then you write some .iso’s to them and they somehow dont work?
Sounds like either a problem with the ISOs or the methodology.
Maybe you could explain more and give some direct information, such as tools used and the output of

sudo fdisk -l
1 Like

Thanks cscs, okay inserted a drive that is readable on other machines & even mounts in Windows … but not here:

Disk /dev/sdd: 29.72 GiB, 31914983424 bytes, 62333952 sectors
Disk model: STORAGE DEVICE  
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x89ff0000

Device     Boot      Start        End Sectors   Size Id Type
/dev/sdd1  *            64     499967  499904 244.1M  6 FAT16
/dev/sdd3       3214935808 3214935808       0     0B  0 Empty

Are your certain the cardreader is OK?

The second partition is missing and the third partition has equal start and end sector.

Make sure you flush all data to the device before removing it - it is a common error - removing the storage device too soon.

I’ve two different card readers and both produce the same result. Perhaps I will try this card on my Manjaro laptop and see what it says. I’ll post later.