Mullvad VPN prevents internet connection while on


I’m having trouble connecting to internet after updating to latest Mullvad VPN 2022.3.
Once or twice it has worked for a moment, but then the connection drops and Mullvad client displays a message saying something like “Firewall rules couldn’t be updated, consider updating kernel”. I’m using the LTS kernel, I also tried the latest kernel, but it didn’t solve this problem. Any suggestions what I could do to fix the issue?

Where did you install mullvad from/how are you using it ?

I was running kernel 5.9 but booted into 5.15.60 to test. I’m using the same mullvad version but have the gui installed from aur

So far no issues at all with connection drops on either kernel

I installed it using the graphical package/update manager. Now I just updated and removed orphan packages from my computer and Mullvad started working without issues, at least so far so good. So, I consider the problem solved.

…except no, it only worked for a few hours :sob: :cry:
Now it’s disconnected again if I try keep Mullvad on. I can’t get anything connected to internet.

There are several mullvad clients/guis in the aur all maintained by @Yochanan (manjaro team member). I’m using the beta bin file I linked, have you changed anything at all in the settings?

I somehow (probably via trial and error) figured out that the problem was tunneling with wireguard -protocol . I switched to OpenVPN and it worked, I got connection to internet. Later I switched back to WG and it’s been working fine since.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.