Mullvad VPN PGP signatures could not be verified even with keys

Even after verifying my keys, I still get (sudo pamac install mullvad-vpn):

Verifying source file signatures with gpg…
mullvadvpn-app git repo … SIGNATURE NOT FOUND
mullvadvpn-app-binaries git repo … SIGNATURE NOT FOUND
==> ERROR: One or more PGP signatures could not be verified!

here is my output for gpg --list-keys

pub rsa4096 2016-10-27 [SC]
uid [ultimate] Mullvad (code signing)
sub rsa4096 2016-10-27 [E]
sub rsa4096 2016-10-27 [S]

pub rsa4096 2015-07-08 [SC]
uid [ full ] Linus Färnstrand (code signing key)
sub rsa4096 2015-07-08 [E]
sub rsa4096 2016-10-31 [S]

pub rsa4096 2019-10-01 [SC]
uid [ full ] David Lönnhager (code signing)
sub rsa4096 2019-10-01 [E]

I already saw the Mullvad VPN / verifying signatures? forum and followed the steps on the official website. (sorry, I can’t include links for some reason.)

This is also a fresh install of Manjaro with no prior configurations.

Not an expert by any means but sudo shouldn’t be used with pamac from everything I’ve read. Looked in pamac gui and there’s several versions of mullvad beta and not beta and bin and none bin files.

I just installed mullvad-von 2021.2-4 (the none bin file). I got prompted to import the keys and after that it built successfully


wow, it works now. It works with pamac install mullvad-vpn. thanks for catching on that mistake.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.