Mu-editor fails both from the AUR and Snap Store

Hi everyone!
I installed mu-editor because I am learning Python. A few days to be honest.
As soon as I tried to launch it from the Gnome environment or the terminal, I got the following error:

TypeError: arguments did not match any overloaded call:
move(self, QPoint): argument 1 has unexpected type ‘float’
move(self, int, int): argument 1 has unexpected type ‘float’
[I found a fix here: bugzilla.redhat.c0m/show_bug.cgi?id=2008378 but I am not sure which file to modify. Can anyone help?
Thank you all,

for the above link replace .c0m with com.
Thank you :grin:

You could try the appimage from the developer (How to install Mu on Linux), although it might not work on Arch (see next post from @omano).

Regardless, this might help you: Moving window error, provided "float" values should be "int". · Issue #2337 · mu-editor/mu · GitHub

From what I read this program is known to have issues with Arch distro, comment says there is same issue, and the AUR maintainer even orphaned the package because he’s tired of having to deal with these issues, apparently even the AppImage of the application wouldn’t work on Arch distro.

SpotlightKid commented on 2022-02-23 18:28 (UTC)

The new 1.1.x release of mu-editor adds several dependencies on Python packages, which are not yet packaged for the AUR and also sets max version number restrictions on several packages, which will not work with Arch either.

Since I have not actually used mu-editor in several years and I am tired of dealing with these kinds of projects, which make life unnecessarily complicated for distribution packagers, I am orphaning this package now.

If you want to use mu-editor 1.1.x, I would like to suggest you use pipx to install it, but, alas, this doesn’t work, since its dependencies are unresolvable.

I don’t have a solution, but is there a reason you want to use this application? There should be many other IDE for Python.

I really love mu-editor as it is really simple and is really handy, especially to noobs like me :slight_smile:
Anyway, I would love to have mu in the repositories but if that’s not convenient for the majority of users, then I trust and thank you -I thank the whole community- for maintaining the best repository in the world.
I used manjaro a couple of years ago and I am amazed of how far it improved as a distro. I was used to the ubuntu store but, man, the possibilities when adding aur and snap store to pamac, are endless.
Anyway, it was a really simple fix. I post the solution here if someone else wishes to solve this:
sudo gedit /usr/lib/python3.10/site-packages/mu/interface/
Ctrl+f and search for self.move.
You then replace self.move((screen.width() - size.width()) / 2 to self.move((screen.width() - size.width()) // 2 (you add one more slash converting the value to a float number).
Please, if its possible give a second chance to mu editor.
Thank you for everything…Eddie.

While you’re at it, do them all Avoid TypeErrors when moving windows to float positions by hroncok · Pull Request #1828 · mu-editor/mu · GitHub (this was actually in the link you posted originally).

then make a request about it, but as said before apparently packaging it for Manjaro would require extra work because of the application requirement not fitting the Arch world (program requires specific version of things, and doesn’t allow older or newer version. Also as contradictory as it sounds (because Manjaro team doesn’t support the AUR and often remind it to people), if a program is in the AUR they tend to use that to not add a program to the repositories, but then you’re being told that using the AUR is not supported :upside_down_face:

I don’t know what you mean.

The mu-editor AUR package has been flagged out of date for over 6 months, so I orphaned it. You may now adopt the package and update it. :wink:

The Snap package is apparently abandoned as it had not been updated since 2018.

I’d suggest using the PyCharm Community Edition.

Best method of installing is to use the toolbox app.

This modification of code line did not work for me.

What worked for me was to install python module contourpy and to set the move()-command to position 0,0 like:

# run this in console
pip install contourpy

# sudo gedit /usr/lib/python3.10/site-packages/mu/interface/
# comment out existing 
# self.move((screen.width() - size.width()) / 2 to self.move((screen.width() - size.width() ...) and add below

self.move(0, 0)