Mtp cannot access via terminal

When I attach my android phone, I can access the data with dolphin, showing up as

mtp:/GM1901/Internal shared storage/

but I am unable to access this location via the terminal.

Others have reported that there would be a mount point in /run/user/$USER/gvfs/ ( but this is not the case in my system.

I need to be able to access via the terminal because I need to rsync data to the phone.

you have to first access it via File Manager (Dolphin in your case)
then it is accessible via that path

where $USER is your user ID (the number, not the name)

… I don’t know of a way to do it without first using the file manager to “mount” it …

the full path for me/my phone is:

For file transfer I use either the graphical file manager directly, or I use “mc” (a terminal file manager)
I never tried using rsync with the phone storage.

Mh I tried that, but /run/user/1000/gvfs remained an empty directory while I was browsing around the phone with a separate dolphin window.

I do not know. :man_shrugging:
It works for me that way.
Not with Dolphin, though - I’m on Xfce4 and using the Thunar File Manager.

Can’t help or give advice for Plasma/KDE. Sorry.
I would not expect it to behave differently - but apparently it does.

it"s only for xfce/gnome, with dolphin is kio ‘/run/user/1000/kioXXXXX’
For found directory (if exists ?), in dolphin, open terminal with F4 key (and run pwd)

1 Like

nope, there is no such folder in /run/user/1000/.
In dolphin, the address shown (when pressing Ctrl+L) is mtp:/GM1901/Internal shared storage/. If I open the terminal from there (F4 or Shift+F4) I end up in ~.

I confirm - the device is accessible in Dolphin, go to the root of the Phone’s file system or to anywhere,
to the DCIM folder, for example, where the camera’s pictures are,
and F4 will simply open in $HOME
I can’t figure out a way to get a location in the file system.
I usually use mc instead of Dolphin - using it, I can’t access the phones storage anywhere while I can do that in Dolphin.
(I had too much time on my hands and was curious, so I checked in a Manjaro KDE/Plasma Virtual Machine to which I passed the USB device …
since I do not use Plasma/KDE I will not pursue this further)

1 Like

I no use dolphin for access to my phone in konsole but go-mtpfs (not in manjaro repos)