Mpv has switched to a very narrow font

mpv is being weird about fonts.
I managed to set the OSD to something less squished with osd-font='Droid Sans' , but the info is still shown with what mpv has deemed as its current default font:

Here is what the OSD will look like, if I haven’t configured a font for it myself:

My ~/.config/mpv/mpv.conf:

osd-font='Droid Sans'
  Kernel: 6.9.1-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9-x86_64
    root=UUID=c28c9ba1-1ab9-48ed-a6c3-a5cf6794acea rw apparmor=1
    security=apparmor udev.log_priority=3 sysrq_always_enabled=1 nowatchdog
    mitigations=off amd-pstate=guided amdgpu.ppfeaturemask=0xffffffff
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
    wm: kwin_wayland with: krunner vt: 1 dm: SDDM Distro: Manjaro
    base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: B450M MORTAR MAX (MS-7B89) v: 1.0
    serial: <superuser required> uuid: <superuser required> UEFI: American
    Megatrends LLC. v: 2.K0 date: 10/20/2023
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 0 microcode: 0xA20102B
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 4056 high: 4650 min/max: 550/4651 boost: enabled
    scaling: driver: amd-pstate governor: schedutil cores: 1: 3918 2: 3915
    3: 3735 4: 4011 5: 3754 6: 4649 7: 4280 8: 3718 9: 3800 10: 4400 11: 3851
    12: 4650 bogomips: 88825
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable; IBPB: disabled; STIBP: disabled;
    PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] vendor: Sapphire
    driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
    built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
    empty: DP-2, HDMI-A-1, HDMI-A-2, Writeback-1 bus-ID: 28:00.0
    chip-ID: 1002:747e class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu dri: radeonsi gpu: amdgpu
    display-ID: 0
  Monitor-1: DP-1 res: 2560x1440 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.7-arch10.3
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7800 XT (radeonsi
    navi32 LLVM 17.0.6 DRM 3.57 6.9.1-1-MANJARO) device-ID: 1002:747e
    memory: 15.62 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 11 device: 0 type: discrete-gpu name: AMD
    Radeon RX 7800 XT (RADV NAVI32) driver: mesa radv v: 24.0.7-arch10.3
    device-ID: 1002:747e surfaces: xcb,xlib,wayland
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 28:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: SAVITECH ODAC-revB driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-2:3
    chip-ID: 262a:1048 class-ID: 0102
  API: ALSA v: k6.9.1-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Supported mdraid levels: raid0
  Device-1: md0 maj-min: 9:0 type: mdraid level: raid-0 status: active
    size: 744.74 GiB
  Info: report: N/A blocks: 780914688 chunk-size: 512k super-blocks: 1.2
  Components: Online:
  0: sdb maj-min: 8:16 size: 186.31 GiB
  1: sdc maj-min: 8:32 size: 186.31 GiB
  2: sdd maj-min: 8:48 size: 186.31 GiB
  3: sde maj-min: 8:64 size: 186.31 GiB
  Local Storage: total: 1.18 TiB used: 849.27 GiB (70.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 910 200GB
    size: 186.31 GiB block-size: physical: 4096 B logical: 512 B tech: SSD
    serial: N/A fw-rev: a424
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 910 200GB
    size: 186.31 GiB block-size: physical: 4096 B logical: 512 B tech: SSD
    serial: N/A fw-rev: a424
  ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 910 200GB
    size: 186.31 GiB block-size: physical: 4096 B logical: 512 B tech: SSD
    serial: N/A fw-rev: a424
  ID-5: /dev/sde maj-min: 8:64 vendor: Samsung model: SSD 910 200GB
    size: 186.31 GiB block-size: physical: 4096 B logical: 512 B tech: SSD
    serial: N/A fw-rev: a424
  ID-1: / raw-size: 465.26 GiB size: 456.89 GiB (98.20%)
    used: 301.34 GiB (66.0%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 1 (default 60) cache-pressure: 30 (default 100)
    zswap: yes compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 8 GiB used: 8.5 MiB (0.1%) priority: -2
    file: /mnt/faaast/swap
  System Temperatures: cpu: 38.0 C mobo: 41.0 C gpu: amdgpu temp: 42.0 C
    mem: 55.0 C
  Fan Speeds (rpm): fan-1: 0 fan-2: 1308 fan-3: 852 fan-4: 581 fan-5: 939
    gpu: amdgpu fan: 0
  Memory: total: 32 GiB available: 31.27 GiB used: 8.62 GiB (27.6%)
  Processes: 350 Power: uptime: 22h 43m states: freeze,mem,disk
    suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown,
    reboot, suspend, test_resume image: 12.49 GiB
    services: org_kde_powerdevil,upowerd Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1581 libs: 458 tools: pamac Compilers:
    gcc: 14.1.1 Shell: Zsh v: 5.9 running-in: yakuake inxi: 3.3.34

so, you don’t like the default font
and you’d like to alter it

osd-font='Droid Sans

seems to miss a ’ at the end



seems also “wonky”

How do you think altering the font should work?

That didn’t come through from copy-pasting, for some reason.

That was the only way to limit the available subtitles of a YouTube video to ones I could use. This came from a situation years back, where if a video had subtitles for tens of different languages, it would increase the delay until playback would start. It also requires the empty ytdl-raw-options-add=write-subs= below it to work.

It’s not as it was just yesterday, that is all.

Edit: It seems I missed a part in the master manual of mpv.
I created a file ~/.config/mpv/script-opts/stats.conf, dropped font='Droid Sans' (even font='' works, as long as I have osd-font='Droid Sans' inside mpv.conf) inside, and the font for the statistics is more sane again:

mpv seems to insist on using the condensed variant of Noto Sans by default, if that happens to be the default system font, as it is for me.

something is suddenly different
without you having changed anything


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.