Mpv doesn't open any video files

Hello everybody…

I recently upgrade my system from official repository and now mpv (my videoplayer) doesn’t open any video file but it’s opening compress audio files (.mp3) without problems. Before the upgrade my system work fine but with the last pacman -Syu the problem began.

Theres my uname -a output:

Linux Trilobite 5.14.21-2-MANJARO #1 SMP PREEMPT Sun Nov 21 22:43:47 UTC 2021 x86_64 GNU/Linux

Here is my inxi -Fx output:

inxi -Fx                                              ✔  8m 40s  
  Host: Trilobite Kernel: 5.14.21-2-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.1.0 Desktop: LXQt 1.0.0 Distro: Manjaro Linux base: Arch Linux
  Type: Portable System: Gateway product: MX6433 v: 3402558R
    serial: <superuser required>
  Mobo: Gateway model: N/A v: 68.04 serial: <superuser required>
    BIOS: Gateway v: 68.04 date: 01/24/06
  ID-1: BAT1 charge: 1.8 Wh (100.0%) condition: 1.8/51.8 Wh (3.4%)
    volts: 12.4 min: 10.8 model: SANYO MAL32b status: Full
  Info: single core model: AMD Turion 64 Mobile ML-30 bits: 64 type: UP
    arch: K8 rev.E rev: 2 cache: L1: 128 KiB L2: 1024 KiB
  Speed (MHz): 1600 min/max: 800/1600 core: 1: 1600 bogomips: 3184
  Flags: lm nx pae sse sse2 sse3
  Device-1: AMD RS480M [Mobility Radeon Xpress 200] vendor: Gateway
    driver: radeon v: kernel bus-ID: 01:05.0
  Display: x11 server: driver: loaded: ati,radeon
    unloaded: modesetting resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD IXP SB400 AC97 Audio vendor: Gateway MX6421
    driver: snd_atiixp v: kernel bus-ID: 00:14.5
  Sound Server-1: ALSA v: k5.14.21-2-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.42 running: no
  Device-1: Marvell 88E8036 PCI-E Fast Ethernet vendor: Gateway driver: sky2
    v: 1.30 port: a000 bus-ID: 03:00.0
  IF: enp3s0 state: down mac: 00:e0:b8:b6:91:5b
  Device-2: Realtek RTL-8185 IEEE 802.11a/b/g Wireless LAN
    driver: rtl818x_pci v: kernel port: b000 bus-ID: 05:02.0
  IF: wlp5s2 state: up mac: 00:c0:a8:c8:1f:a1
  IF-ID-1: outline-tun0 state: down mac: N/A
  Local Storage: total: 74.53 GiB used: 56.45 GiB (75.7%)
  ID-1: /dev/sda vendor: Fujitsu model: MHV2080AT PL size: 74.53 GiB
  ID-1: / size: 18.33 GiB used: 16.14 GiB (88.0%) fs: ext4 dev: /dev/sda3
  ID-2: /home size: 54.64 GiB used: 40.31 GiB (73.8%) fs: ext4
    dev: /dev/sda2
  Alert: No swap data was found.
  System Temperatures: cpu: 56.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 153 Uptime: 1h 53m Memory: 1.38 GiB used: 1.22 GiB (88.2%)
  Init: systemd Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1142
  Shell: Zsh v: 5.8 inxi: 3.3.11

I tried to debug mpv using gdb and this the output:

(gdb) run 1.avi 
Starting program: /usr/bin/mpv 1.avi
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".
[New Thread 0x7fffe392e640 (LWP 15220)]
[New Thread 0x7fffe312d640 (LWP 15221)]
[New Thread 0x7fffe292c640 (LWP 15222)]
[New Thread 0x7fffe212b640 (LWP 15223)]
[New Thread 0x7fffe192a640 (LWP 15224)]
[New Thread 0x7fffe1129640 (LWP 15225)]
[Thread 0x7fffe1129640 (LWP 15225) exited]
[New Thread 0x7fffe1129640 (LWP 15227)]
[New Thread 0x7fffe1129640 (LWP 15228)]
[New Thread 0x7fffcba9f640 (LWP 15229)]
[Thread 0x7fffe1129640 (LWP 15227) exited]
 (+) Video --vid=1 (mpeg4 640x480 23.976fps)
 (+) Audio --aid=1 (mp3 2ch 48000Hz)
[New Thread 0x7fffcb29e640 (LWP 15230)]
[New Thread 0x7fffcb29e640 (LWP 15231)]
[Thread 0x7fffcb29e640 (LWP 15230) exited]
[New Thread 0x7fffc8c7f640 (LWP 15232)]
[New Thread 0x7fffb57d1640 (LWP 15233)]
[New Thread 0x7fffa4fd0640 (LWP 15234)]
AO: [pulse] 48000Hz stereo 2ch float
VO: [gpu] 640x480 yuv420p

Thread 12 "mpv/vo" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffcb29e640 (LWP 15231)]
0x00007fffc94cc87c in ?? () from /usr/lib/dri/

I also try with vlc but i got the same result (videoplayer start to open video but it stop and close launching a coredump file)

Even when you uninstall and reinstall mpv or vlc the error still happens.

5.14 is eol. Switch to a supported kernel first:

don’t remove a active kernel

1 Like

Just checking: what version are you using?

pacman -Q mpv vlc

This are my actual version of mpv and vlc…

pacman -Q mpv vlc                                                ✔ 
mpv 1:0.34.0-4
vlc 3.0.16-6

This is the installed kernells on my laptop:

sudo mhwd-kernel -li                                             ✔ 
[sudo] password for neji: 
Currently running: 5.14.21-2-MANJARO (linux514)
The following kernels are installed in your system:
   * linux510
   * linux514

I’m gonna try with linux515 to see if the problem disappear … ¿Or I must to use an LTS kernel like linux510 or similar?

5.10 is already installed on your system so go with that first.

Reboot into 5.10 (tap Esc during boot to show grub)
Double check your running kernel is not 5.14 then remove it:

uname -r #to check kernel version
sudo mhwd-kernel -r linux514
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

I follow your advice and went down to linux510 but unfortunally the problem is still here… :frowning:

    ~  mpv 1.avi                                              ✔  1m 6s  
 (+) Video --vid=1 (mpeg4 640x480 23.976fps)
 (+) Audio --aid=1 (mp3 2ch 48000Hz)
AO: [pulse] 48000Hz stereo 2ch float
VO: [gpu] 640x480 yuv420p
zsh: segmentation fault (core dumped)  mpv 1.avi

    ~  uname -r                                         SEGV ✘  1m 23s  

Perhaps the problems it’s not the Kernell but anything related to the video driver or something…
When ir try to debug mpv i got this output:

Thread 12 "mpv/vo" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffcb29e640 (LWP 3875)]
0x00007fffc94cc87c in ?? () from /usr/lib/dri/

So i think i must look for video driver or something related… the curious thing it’s that before i upgrade the system it worked fine.

$ LANG=C pacman -Qo /usr/lib/dri/
/usr/lib/dri/ is owned by mesa 21.3.2-1

AFAIK mesa is used for OpenGL rendering. Let’s check your mpv settings.

cat ~./config/mpv/mpv.conf

Houston we got a problem…

cat /home/neji/.config/mpv/mpv.conf                            1 ✘ 
cat: /home/neji/.config/mpv/mpv.conf: No existe el fichero o el directorio

It seems that i have no any file named mpv.conf on that folder

LANG=C pacman -Qo /usr/lib/dri/                     1 ✘ 
/usr/lib/dri/ is owned by mesa 21.3.2-1

That means you use the default configuration, so GPU-accelerated OpenGL output.

The recommended output driver is --vo=gpu, which is the default.

mpv has many options for video output, so using one with broader compatibility such as xv might help work around the issue.

Although this doesn’t really solve the source of the issue… Since the error comes from a mesa library, i can only suggest reinstalling the package…

I’ve already reinstall the package (mpv and mesa) but the issue still remains.

I’ve reinstalled my system (LXQt) using and old ISO that I downloaded once from Community in the oficial site.
The system install well but when I make an upgrade (sudo pacman-mirrors --fasttrack =5 && sudo pacman -Syyu) it fall into the same loop (It plays audio but it doesn’t play any video) :disappointed:

Since the issue may be linked to OpenGL, let’s try to complete that:

sudo pacman -S mesa-utils
inxi -G

This is my inxi -G output:

inxi -G                                   
  Device-1: AMD RS480M [Mobility Radeon Xpress 200] driver: radeon v: kernel
  Display: x11 server: driver: loaded: ati,radeon
    unloaded: modesetting resolution: <missing: xdpyinfo>
  OpenGL: renderer: ATI RS480 v: 2.1 Mesa 21.3.2

I’m just gonna toss out that the radeon card there is over 17 years old.
Whatever that means to anyone.

He could just
at least try
using a different
video output
like @maycne.sonahoz suggested
I know that I have used this … way back when (at least a decade ago)
when the default would not work with my hardware.

Yup … And I have been documenting it since 2 forums ago at least … though its almost always about VLC’s automatic (smplayer/mpv/etc never seem to have issue) … but the fact that its so old, makes things you wouldnt normally expect more likely.

This might be an ok test, as it will loop through the listed outputs until one works, and the trailing comma will also try unlisted items if none of them work.

mpv 1.avi --vo=vdpau,vaapi,sdl,xv,x11,

I’m a linux user since 2006 and I admit my hardware it’s not the best from the market (I’m just kidding my Acer Aspire 5 it’s on the way while we’re speaking and I like to use this old hardware to try new version and new systems) and always used this settings, the same settings and hardware that worked perfectly with Manjaro Nibia 21.2 until came the last upgrade that remove or change something that made my old laptop almost unusefull…

I wish I could help.
But I can’t.
It’s strange that it used to work, but now it doesn’t.

If you just did updates and nothing else
this should not have happened.
… but it did

I have no clue …

… I’m a Linux user since around 1998 :wink: