Mplayer 38412-1 doesn't work

FYI After updates around end of March 2023, mplayer stopped working (no sound, but no error either). (I invoke it as mplayer -nolirc GIT/gnome-pomodoro/data/sounds/bell.ogg -ao pulse, but mplayer -nolirc GIT/gnome-pomodoro/data/sounds/bell.ogg -ao alsa is quiet, too.)

I guess the problem comes from the mplayer update (rather than libraries/kernel), the current 38412-1. (The same problem with any of my current kernels: 6.1.23-1 LTS, 6.2.10-1, 6.3.0rc5-1.)
(The sound file didn’t change, and it keeps playing with smplayer or mpv.)

Workarounds (for headless): mpv --volume=30 GIT/gnome-pomodoro/data/sounds/bell.ogg.

Maintainers or any other expert:

  • is there any better place to report this? (This comes from “Official Repositories (extra)”
  • MPlayer - The Movie Player has a newer version, please pull.

I cannot reproduce this problem.
Unstable Branch (V. 38412-1 … should be same on all branches)

Please provide mroe information, such as your system info and your version of mplayer package, etc.

uname -a
Linux spectre 6.3.0-1-MANJARO #1 SMP PREEMPT_DYNAMIC Mon Apr  3 10:46:56 UTC 2023 x86_64 GNU/Linux

# but the sound doesn't come out, regardless of the kernel, see all three kernel versions above.

mplayer --help
MPlayer SVN-r38412 (C) 2000-2023 MPlayer Team
226 audio & 469 video codecs

I did Add/Remove Software > mplayer > “Reinstall”, still the same.

Unlikely to be related, but I’ve just noticed that my “Settings” application > About > GNOME Version is “Not Available” (but it does show that I’m on X11):

My overall installation IS OLD (almost 4 years), but up-to-date and pretty standard.

First… please edit the thread title to portray the audio issue.

Then… your version is the same as mine.

I wonder if this might have something to do with hardware acceleration and/or the removal of nonfree codecs from regular mesa ? (more comparison - I do use the nonfree repo)

Sorry. I guess that topic is locked for TL2+
The gist is that some non-free codecs were pulled from the upstream mesa packages, so our repo packages followed suit … theres an additional repo for people who want the (un)patched versions back.
The repo and instructions are here

I suppose you could similarly try to configure settings in smplayer to de-or-re-activate hardware acceleration while using the mplayer backend.

mplayer is not flagged out-of-date on Arch so there is no updated version for Manjaro to inherit yet
Arch Linux - mplayer 38412-1 (x86_64)

I downloaded sound file from
also tried an installed sound file /usr/share/sounds/freedesktop/stereo/bell.oga

Mplayer appears to work from terminal responses but there is nothing audible and audio stream is not shown in pavucontrol

If mplayer command is replaced with paplaypaplay ~/Downloads/bell.ogg – sound plays correctly

If the ogg file is reencoded to another file format, mplayer can play sound correctly:
mplayer -nolirc ~/Downloads/bell.wav -ao pulse
mplayer -nolirc ~/Downloads/bell.mp3 -ao pulse

so the issue appears to be specific to mplayer decoding ogg-vorbis

1 Like

Ah there we are. I can confirm this.