Moving windows is 60hz on a 144hz monitor when using multiple displays


When I connect my second 60hz monitor, moving windows looks like its 60hz on my 144hz monitor. I recorded a video here Manjaro 144hz - YouTube. It’s a bit hard to see the difference because all the encoding (and youtube is 60 fps), but it’s noticeable that moving windows is not 144+ fps. Single monitor window moving is smooth on my 165hz laptop screen and 144hz monitor when the 60hz display is not connected, but when I connect 2 displays, moving windows slow down. This isn’t a performance issue as I got a pretty beefy laptop + this is not happening on Windows.

Here is my inxi -Fxz

System:    Kernel: 5.11.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: KDE Plasma 5.21.2 
        Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: ROG Zephyrus G15 GA503QR_GA503QR v: 1.0 serial: <filter> 
        Mobo: ASUSTeK model: GA503QR v: 1.0 serial: <filter> UEFI: American Megatrends LLC. v: GA503QR.404 
        date: 02/08/2021 
Battery:   ID-1: BAT0 charge: 91.1 Wh condition: 91.1/90.0 Wh (101%) model: ASUSTeK ASUS Battery 
        status: Not charging 
        ID-2: hidpp_battery_0 charge: N/A condition: N/A model: Logitech G Pro Wireless Gaming Mouse 
        status: Discharging 
CPU:       Info: 8-Core model: AMD Ryzen 9 5900HS with Radeon Graphics bits: 64 type: MT MCP arch: Zen 3 rev: 0 
        L2 cache: 4 MiB 
        flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 105453 
        Speed: 1286 MHz min/max: 1200/3300 MHz boost: enabled Core speeds (MHz): 1: 1286 2: 1621 3: 3672 
        4: 2816 5: 1915 6: 1915 7: 1916 8: 1681 9: 1315 10: 1913 11: 1512 12: 1606 13: 1357 14: 1915 15: 1905 
        16: 1818 
Graphics:  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia v: 460.56 
        bus ID: 01:00.0 
        Device-2: Advanced Micro Devices [AMD/ATI] vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 07:00.0 
        Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting,nvidia resolution: 1: 1920x1080~60Hz 
        2: 1920x1080 
        OpenGL: renderer: GeForce RTX 3070 Laptop GPU/PCIe/SSE2 v: 4.6.0 NVIDIA 460.56 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus ID: 07:00.1 
        Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK 
        driver: N/A bus ID: 07:00.5 
        Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
        v: kernel bus ID: 07:00.6 
        Device-4: Microdia NexiGo HD Webcam type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-1.2.4:12 
        Device-5: Kingston HyperX Cloud Flight S type: USB driver: hid-generic,snd-usb-audio,usbhid 
        bus ID: 1-1.3.3:13 
        Device-6: JMTek LLC. USB PnP Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid 
        bus ID: 1-1.3.4:14 
        Sound Server: ALSA v: k5.11.2-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 
        v: kernel port: d000 bus ID: 03:00.0 
        IF: enp3s0 state: down mac: <filter> 
        Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: d000 bus ID: 04:00.0 
        IF: wlp4s0 state: up mac: <filter> 
        IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
        IF-ID-2: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus ID: 1-4:5 
        Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 1.84 TiB used: 76.15 GiB (4.0%) 
        ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB temp: 54.9 C 
        ID-2: /dev/nvme1n1 vendor: SK Hynix model: HFM001TD3JX013N size: 953.87 GiB temp: 51.9 C 
Partition: ID-1: / size: 899.02 GiB used: 76.13 GiB (8.5%) fs: ext4 dev: /dev/nvme0n1p2 
        ID-2: /boot/efi size: 299.4 MiB used: 25.5 MiB (8.5%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 66.0 C mobo: N/A 
        Fan Speeds (RPM): cpu: 2400 
        GPU: device: nvidia screen: :0.0 temp: 56 C device: amdgpu temp: 63.0 C 
Info:      Processes: 446 Uptime: 3m Memory: 38.68 GiB used: 3.75 GiB (9.7%) Init: systemd Compilers: 
        gcc: 10.2.0 Packages: 1292 Shell: Zsh v: 5.8 inxi: 3.3.01 

Let me know if anyone has ideas! I’ll try them out. Thanks.

Did you change the refresh rate in your display settings? Should be easy as opening up the Display GUI and changing it to 144, at least on KDE.

I run a 75hz, 144hz, 75hz monitor fine.

Yes, I have it in the video I posted. My refresh rate is set to 144hz and looks like 144hz until I connect the 60hz monitor. But the mouse movement still looks like 144+ fps, it’s just moving windows looks like it’s outputting at 60hz.

Maybe a Freesync / G-sync Problem. Try to disable it.

It’s not software problem, it’s that just it sets different screen mode… When you switch displays, they need common frequency, which is a bug. It can be done so, that it doesn’t make synchronous frame from buffer on both screens, but samples each screen individually like it should been.

Maybe there is old acient way, and that is running full clock FPS, and then drawing every nth and mth shot from each screen.

Limiting FPS is wrothless, and it doesn’t save power, until you underclock something.

These are disabled by default. Also, you can’t use these with multi monitors on X Server. You can only do so on Wayland.

Unfortunately, not everyone can look at videos to help others. It’s best to type out every info you can on the forum in text.

This is false.

  • Some games, such as FFXII Zodiac Age, should be limited to 60fps else during cutscenes, the audio will no longer be in synced. I think the game has a frame rate limiter, but maybe it broke because I used Proton to play it. I have to limit the FPS myself.
  • There is a reason why some games are limited to 30 or 60 fps.
  • FreeSync / G-Sync monitors, it’s best to limit the FPS to the max refresh rate of your monitor.

I have never had any issues at all with mine at different refresh rates. I’ve had monitors with 3 different refresh rates running at the same time before with no issues.

@mike27 idk about other DEs, but if you’re using KDE, try to go into the settings and change the backend renderer of the compositor to see if that does anything. I use OpenGL 3.1 myself.

Good to know @realmain , thank you.

@mike27 good luck :wink:

The video was only about 20 seconds and it was just showing what the issue looked like. I typed all the information in the thread. As for OpenGL, I’m using 3.1 already.