Mouse & touchpad only working with "fallback initramfs"

I have a new Lenovo E14 and the touchpad and mouse only work when I boot with “fallback initramfs”. From what I understand I need to find out the driver that’s missing from the regular boot using lsinitcpio and then use mkinitcpio to add it. However I’m not sure how exactly to do it.

Setup: Lenovo E14, i17 12th gen, XFCE, 5.19.1-3-MANJARO


Hi! Boot normally and issue lsmod > ~/normal.lsmod and then boot into fallback and issue lsmod > ~/fallback.lsmod. Then find what’s missing.

Have you tried a LTS kernel?

EDIT: found this here:

Thanks! Will check later this week (need to work on this machine as well :slight_smile:

FWIW the 5.15 LTS works without an issue.

1 Like

@mbb I ran lsmod on 5.19, 5.19 fallback and 5.15 (last two has a working mouse).

The extra modules I see in the fallback are: elan_i2c, joydev, mousedev and veth. I guess it’s mousedev? How can I check?

I think you can try to put them in /etc/mkinitcpio.conf, at the MODULES=() section. Example:

MODULES=(lz4 lz4_compress)

Then recompile the kernel image with sudo mkinitcpio -p linux519 and reboot to the intended kernel. Don’t compile all the kernel images, because in case it doesn’t boot, you can select another entry in grub. You can start by including all those modules and test. If it works, you can then remove one by one to keep only needed ones.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.