Mouse strange behavior (lags/unpredictable)


I faced strange behavior with my mouse - cursor seems like freezing on UI elements (such like buttons) and make positioning like impossible (no vertical/horizontal force for a while and great after). Little google says it could be compositor, but with GNOME I can’t switch off it (or don’t know how). All “hellpers” tried to be suspended but issue stays with me. Do not mind what can it be, will be very pleasant for any help.

Also, switching to awesome (with stop gdm and starting with startx) granted nothing - mouse still unusable. Graphics under NVIDIA drivers.


After some sort of research - I found no way to solve it out. Several points: around half of year ago anything was find (but die to my 1060 slowly dying had to switch back to Windows), and issue seems to be represented on nvidia stack. Tried to switch to xfce and disabling compositor, also tried to turn on forced full compositor pipeline in nvidia-settings. No luck. Nouveau is not an option (but maybe I’ll try) due to full 3D requirement. I definitely do not know what’s happening, but I becoming to agree with Linus about nvidia and other great corporations. There is NO option to use Linux for gaming as free as Windows. Sad. Maybe (!) there is some set of configurations with working condition to use mouse - I don’t know.

Little more about behavior - trying to reach any controllable UI element will fail cause of mouse speed dramatically fails near one in vertical or horizontal part. Anywhere - browser and windows seems like no limit. Workarounds didn’t tried but they are not an options like open-source drivers. I think, screencast will not show issue - the feeling is locomotive of this pain.

Definately a configuration issue local to your system.

Wayland vs. X11 - before login verify which session you login into - could be Wayland and Nvidia and Wayland is said to be bad combination.

Hi, and sorry for late response, I moved from Manjaro out for now.

It seems to be Xorg, but I did not check that definitely. Also, issue comes from live version, I thought it could be only live-version issue, but not. Mouse is working, but completely unusable, so I dropped it out. Maybe later I will try again and if remember this - will update post.

is it your trackpad or an actual mouse? i had the same problem on my bluetooth mouse, but that was because of the internal battery going bad, i’m using a cheap usb steelseries gaming mouse now, and it worked great on rpi 4b sway manjaro and kde manjaro, also works on omen laptop with ryzen cpu and nvidia gpu, make sure the bottom of the mouse is clean so the laser can tell when you move it… thje steelseries doesn’t juse a red laser under the mouse, it’s almost clear and works on almost any surface, except table with small holes in them!!

i hope we can get this figured out