Mouse Pad Not working

On start up my mouse cursor was not on screen and the mouse pad isn’t working when I click it. I’ve experienced something similar once before with the mouse and it wasn’t hardware, but don’t recall what solved it. I tried an external mouse and it worked straight away, I know it could be a hardware issue, but I want to make sure there is nothing software related before sending it to be repaired. Any thoughts?

My system details are:

Kernel: 5.15.160-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
Desktop: GNOME v: 46.2 tk: GTK v: 3.24.42 wm: gnome-shell
tools: gsd-screensaver-proxy dm: GDM v: 46.2 Distro: Manjaro
Machine: Type: Laptop System: Star Labs product: StarBook v: 1.0

It’s very unlikey to be a hardware problem.

Check Dmesg for Errors:

  • Run dmesg | grep -i touchpad to see if there are any error messages related to it.

I get,

dmesg: read kernel buffer failed: Operation not permitted

sudo dmesg | grep -i touchpad - you need administration right for that

I would suggest you to rather use ubuntu and go into the linux basics first before you use manjaro.

I used sudo also, I get nothing, just a prompt.

Then Check for Driver Issues:

  • Ensure the touchpad driver is loaded. Run lsmod | grep -i psmouse or lsmod | grep -i i2c_hid (depending on your touchpad type).

  • If the driver is not loaded, try loading it manually with sudo modprobe psmouse or sudo modprobe i2c_hid

I suspect it to be a driver module conflict and or maybe it is not loaded.

Are you having touchpad problem of right click ?

You feel it would be a driver even on a system that has been running Manjaro for a few years and hasn’t run any recent updates?

The mouse pad, there is no cursor on screen and if I try to login by pressing the mouse pad it doesn’t react, only when I type a key on the keyboard, so that suggests the whole pad is not active or working.

I have that issue once in a while with my dell laptop since I have it… When I press ctrl + shift + f2 (or was it ctrl + alt + shift + f2 … not remember atm 100%) while booting it reloads the kernel module when the mousepad does not work and then it works again.

I think it is a kernel module + driver issue … but I did not further investigate that issue because that simple solution solves my problems. Since some kernel updates and firmeware updates a while ago I did not have this problem quite a while now.

Do you think changing kernel could help then? I have been thinking of update it, as it’s a little older now.

Absolutely! Switching to the lates LTS Kernel and make a Firmware Bios Update and check if you have the troubles again.

IF laptop touchpad right click is not working on gnome
install dconf editor and go to
/org/gnome/desktop/peripherals/touchpad/click-method
disable default value which is “fingers” and choose custom value “areas”
If this your problem or maybe I did not understand correctly.

OK I’ll try that first, thank you for your help!

418/93 :wink:

1 Like

Your’re welcome. 93’s

So I have updated the kernel and tried manually loading the driver. Currently trying to update the bios/firmware, but that’s a bit more involved as Starlabs have their own custom versions of things like fwupd. Any other ideas I can try while waiting for their support to get back to me?

Not sure of their bios, but normally you should be able by flashing the bios with a simple usb stick where you put the update on. - Further I would also receommend to make a full update and clean your system of all orphaned and old files and dependencies not needed any longer - BEFORE - you flash your bios.

Also make shure that you do not blow your system and get a safe-copy of your most important files not to risk any total loss of all your files and so on.

Let us know if it worked out for you. - Cheers

All working now, thank you for your help.

1 Like

Glad to hear that :slight_smile: You’re Welcome!