Mouse movement causes stuttering, lag, and freezing

Some of the Steam games in my library work fine, but a number of them suffer from stuttering, lag, and freezing that occurs only when the mouse is moved. Quake 3 suffers, but Return to Castle Wolfenstein doesn’t.

Star Wars: Empire At War works fine, but Age of Empires 2 HD edition appears to have this problem and the Cultures games are unplayable because of it.

I tried a number of searches online for fixes and none of the suggested fixes have helped. I’ve tried both a wireless and a wired mouse on different USB ports. Mouse acceleration is disabled, touchpad is disabled,… I even switched Windows Manager from XFCE to KDE because I read the Windows Manager could be the issue. I’m at a loss.

Any help would be much appreciated. Thank you.

In order to do that, we need this kind of information from you:

@Eirinjas, you could try to change mouse polling rate

Thanks for the suggestion. I see no setting for it in the system settings, and I tried several different bash suggestions that didn’t pan out. I wasted hours fruitlessly the other day trying to fix this issue.

You can try following this article:

Thanks. I created the usbhid.conf w/ the line: options usbhid mousepoll=4

Rebooted, ran: systool -m usbhid -A mousepoll

…and the mousepoll was still “0”

This is the debug info, for what it’s worth:

T: Bus=05 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=046d ProdID=c52b Rev=12.01
S: Manufacturer=Logitech
S: Product=USB Receiver
C:* #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr= 98mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=01 Driver=usbhid
E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=8ms
I:* If#= 1 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=02 Driver=usbhid
E: Ad=82(I) Atr=03(Int.) MxPS= 8 Ivl=2ms
I:* If#= 2 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=usbhid
E: Ad=83(I) Atr=03(Int.) MxPS= 32 Ivl=2ms

T: Bus=06 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 5
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0001 Rev= 5.08
S: Manufacturer=Linux 5.8.6-1-MANJARO ohci_hcd
S: Product=OHCI PCI host controller
S: SerialNumber=0000:00:13.0
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

There is Know issues section at the Wiki page - maybe you have already checked them.

As you are using Logitech mouse, maybe this could help you out:

and you can check if your model is in the supported list here

I personally have 2 Glorious Model O and D mice that I use (one is configured with 125Hz and the other is 1000Hz) and luckily I have no issue with both of them in games - I acknowledge that this is specific for my hardware setup, tho.