Mouse keeps "falling asleep"

(I'm not sure if this is a hardware issue or a driver issue so I've posted this to the general board. )

My mouse keeps "sleeping" whenever I don't move the cursor for a few seconds. It takes a few seconds of me moving the mouse and clicking randomly for it to "wake up" and start moving the cursor again.

As you can imagine, this can be very infuriating.

At first i thought it was simply the battery on my wireless mouse dying, but after changing the batteries and testing on a few other wired mice, it seems to be a system issue. These mice all work perfectly fine on other computers as well, so what is going on?

It doesn't seem to be lag, since other programs seem to work as normal all the while this happens- and it happens every SINGLE time I don't move my mouse for a few seconds.

Can anyone help?

(Edit: I've also tried every USB port to check if it was a port thing, and no dice)

System:    Host: manjaro Kernel: 5.4.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.3 
           tk: Qt 5.13.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP ENVY Notebook v: Type1ProductConfigId serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 80D9 v: 64.31 serial: <filter> UEFI: Insyde v: F.25 date: 12/16/2015 
Battery:   ID-1: BAT1 charge: 19.9 Wh condition: 25.9/55.5 Wh (47%) volts: 13.0/11.4 model: COMPAL PABAS0241231 type: Li-ion 
           serial: <filter> status: Charging 
CPU:       Topology: Dual Core model: Intel Core i7-5500U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19161 
           Speed: 985 MHz min/max: 500/3000 MHz Core speeds (MHz): 1: 985 2: 877 3: 929 4: 948 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1600x900~60Hz, 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 19.2.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:160c 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:9ca0 
           Sound Server: ALSA v: k5.4.0-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: N/A port: 3000 
           bus ID: 02:00.0 chip ID: 10ec:8168 
           Device-2: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl v: kernel port: 3000 
           bus ID: 04:00.0 chip ID: 14e4:4365 
           IF: wlp4s0 state: up mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.13 TiB used: 63.60 GiB (5.5%) 
           ID-1: /dev/sda vendor: Western Digital model: WDS240G2G0A-00JH30 size: 223.58 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 0000 scheme: GPT 
           ID-2: /dev/sdb vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 0001 scheme: MBR 
Partition: ID-1: / size: 218.57 GiB used: 63.60 GiB (29.1%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 187 Uptime: 16m Memory: 7.69 GiB used: 1.46 GiB (19.0%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: fish v: 3.0.2 running in: yakuake inxi: 3.0.36 

You could add the kernel option

usbcore.autosuspend=-1

somewhere in the line after

GRUB_CMDLINE_LINUX_DEFAULT="quiet

in your grub file. Edit your /etc/default/grub accordingly by any editor (e.g. nano), and then

sudo update-grub

and reboot.

I guess if you would like to disable the auto-suspend just for an specific device, you could run lsusb with your mouse attached to get its ID. Then you need to edit the file /etc/default/tlp.
Un-commenting the line #USB_BLACKLIST="1111:2222 3333:4444" (deleting the #) and putting the device ID within the quotation marks. Something like: USB_BLACKLIST="1234:5678" and save the file.

Aren't input devices excluded from autosuspend automatically by tlp?

1 Like

I was under the impression, mistakenly, that they are not. But you are right, they should be excluded automatically by tlp. Thanks for pointing it out to me. I stand corrected.

@sh0tybumbati please ignore my post.

1 Like

Forum kindly sponsored by