Mouse cursor jumping to second monitor while moving it

Hi! :slight_smile:
Since upgrading my system yesterday (including a move from kernel 5.11 to 5.12), I’ve had a recurring issue where, now and then when I move my mouse, the cursor will suddenly “jump” to my second monitor; It just disappears from the main monitor, and appears in roughly the same spot on the second monitor (which is a pen display, but the pen isn’t placed anywhere near where the cursor appears). The monitors have different resolutions, but it’ll still appear in the same relative position to the edges. On top of that, I’ve been experiencing more mouse lag than usual. At first I suspected it might be low battery on my mouse (it’s a Logitech M705 “Marathon Mouse”), but switching the batteries didn’t seem to do much. I tried using an old wired mouse and it doesn’t seem to happen then, which would suggest an issue with the wireless connection, the mouse itself, or the Logitech Unifying Receiver. I tried monitoring both mice with xinput test, and at first it looked like the wireless mouse stopped acting up while it was running, but after a few minutes it started happening again.

Anyone got any ideas what might be going on?

Here is the output of `inxi --admin --verbosity=7 --filter --no-host --width`:
~ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=88385d1a-f8d9-442b-bd5e-59038c49c640 rw quiet 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <filter> 
  UEFI: American Megatrends v: P1.60 date: 11/05/2018 
  Device-1: hidpp_battery_0 model: Logitech M705 serial: <filter> charge: 100% 
  rechargeable: yes status: Discharging 
  RAM: total: 31.36 GiB used: 10.3 GiB (32.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 1700X bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 1 stepping: 1 microcode: 8001137 cache: L2: 4 MiB 
  bogomips: 108608 
  Speed: 2801 MHz min/max: 2200/3400 MHz boost: enabled Core speeds (MHz): 
  1: 2801 2: 2231 3: 1885 4: 1882 5: 1882 6: 1882 7: 1926 8: 1883 9: 1770 
  10: 1790 11: 1736 12: 1719 13: 1744 14: 1732 15: 1882 16: 1888 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sha_ni skinit smap smca sme smep ssbd 
  sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext 
  tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Gigabyte 
  driver: nvidia v: 460.73.01 alternate: nouveau,nvidia_drm bus-ID: 23:00.0 
  chip-ID: 10de:1c03 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 compositor: gnome-shell driver: 
  loaded: nvidia display-ID: :1 screens: 1 
  Screen-1: 0 s-res: 5011x3240 s-dpi: 96 s-size: 1326x857mm (52.2x33.7") 
  s-diag: 1579mm (62.2") 
  Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 
  Monitor-2: HDMI-0 res: 3840x2160 hz: 60 dpi: 163 
  size: 597x336mm (23.5x13.2") diag: 685mm (27") 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 
  direct render: Yes 
  Device-1: NVIDIA GP106 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 23:00.1 chip-ID: 10de:10f1 
  class-ID: 0403 
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus-ID: 25:00.3 chip-ID: 1022:1457 class-ID: 0403 
  Device-3: Texas Instruments PCM2902 Audio Codec type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1:6 chip-ID: 08bb:2902 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: no 
  Sound Server-4: PipeWire v: 0.3.26 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8168 v: 8.048.03-NAPI modules: r8169 port: f000 
  bus-ID: 1f:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp31s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB 
  driver: btusb v: 0.8 bus-ID: 3-3:4 chip-ID: 0a12:0001 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Message: No logical block device data found. 
  Device-1: luks-7a1f7633-49b3-4723-bf4c-82dcc1cd5a9c maj-min: 254:1 
  type: LUKS dm: dm-1 size: 931.51 GiB 
  p-1: sda maj-min: 8:0 size: 931.51 GiB 
  Device-2: luks-545675cd-3ec2-4adc-930e-e111cee266b9 maj-min: 254:0 
  type: LUKS dm: dm-0 size: 237.96 GiB 
  p-1: nvme0n1p2 maj-min: 259:2 size: 237.97 GiB 
  Message: No RAID data found. 
  Local Storage: total: 6.6 TiB used: 2.77 TiB (42.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: R0906I scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 4B6Q 
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST31000528AS 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC3E scheme: MBR 
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Seagate model: Expansion Desk 
  size: 4.55 TiB block-size: physical: 4096 B logical: 512 B serial: <filter> 
  rev: 0909 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 237.96 GiB size: 233.23 GiB (98.01%) 
  used: 185.4 GiB (79.5%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
  mapped: luks-545675cd-3ec2-4adc-930e-e111cee266b9 label: N/A 
  uuid: 88385d1a-f8d9-442b-bd5e-59038c49c640 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 13.9 MiB (2.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A 
  uuid: 08EA-C1F1 
  ID-3: /mnt/126c42d1-afff-41f1-8331-afb0049be8e3 raw-size: 931.51 GiB 
  size: 916.77 GiB (98.42%) used: 623.64 GiB (68.0%) fs: ext4 dev: /dev/sdb1 
  maj-min: 8:17 label: HDD Secrets uuid: 126c42d1-afff-41f1-8331-afb0049be8e3 
  ID-4: /run/media/william/Seagate Expansion Drive raw-size: 4.55 TiB 
  size: 4.55 TiB (100.00%) used: 1.36 TiB (29.8%) fs: ntfs dev: /dev/sdc2 
  maj-min: 8:34 label: Seagate Expansion Drive uuid: C06C77346C7723F6 
  ID-5: /run/timeshift/backup raw-size: 931.51 GiB size: 931.51 GiB (100.00%) 
  used: 640.61 GiB (68.8%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1 
  mapped: luks-7a1f7633-49b3-4723-bf4c-82dcc1cd5a9c label: SATA SSD 
  uuid: 1b9b0e8f-47e7-4be0-9bd2-500975d6a425 
  Alert: No swap data was found. 
  ID-1: /dev/sdc1 maj-min: 8:33 size: 128 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-5:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c52b class-ID: 0300 
  Device-2: 1-6:3 info: Holtek USB-HID Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 4 rev: 1.1 speed: 12 Mb/s 
  power: 500mA chip-ID: 04d9:a131 class-ID: 0300 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 2-2:2 info: Seagate RSS LLC Desktop HDD 5TB (ST5000DM000) 
  type: Mass Storage driver: uas interfaces: 1 rev: 3.0 speed: 5 Gb/s 
  power: 8mA chip-ID: 0bc2:331a class-ID: 0806 serial: <filter> 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-1:6 info: Texas Instruments PCM2902 Audio Codec type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 08bb:2902 class-ID: 0300 
  Device-2: 3-2:5 info: Tablet Monitor type: Mouse driver: uclogic,usbhid 
  interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 256c:006e 
  class-ID: 0301 
  Device-3: 3-3:4 info: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 0a12:0001 class-ID: e001 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 45.5 C mobo: 0 C gpu: nvidia temp: 56 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 25% 
  Processes: 498 Uptime: 23h 23m wakeups: 404 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1829 
  pacman: 1815 lib: 455 flatpak: 0 snap: 14 Shell: Zsh v: 5.8 
  running-in: gnome-terminal inxi: 3.3.04 
1 Like

First port of call with stuff like this is to try one of the LTS versions of the kernel, so did you try 5.10 and 5.4 already seeing your machine is from 2018 and I can’t see any exotic hardware in your inxi output that would require 5.11 or 5.12…

If you don’t know how to do that, please shout out!


Thanks! That’s true, that’s what I’ll usually do when something breaks on upgrade, but somehow I forgot it this time. I suppose this is what happens when you have too many other things going on at once and something goes wrong on your computer, haha. I gave just rebooting another shot first and it seemed to work for a while but then it started acting up again, so back to 5.10 I went and now it’s working fine again. I recall there being some reason for why I updated to 5.12 in the first place, but I can’t remember what, so until I remember I’ll just stick with 5.10. :sweat_smile:

1 Like

Update: It kept working without issue using 5.10 until I opened Steam today, at which point it started happening again. I wonder if Steam is doing it somehow, or if that’s just a coincidence.

Reboot and try again.
If you can reproduce it, it’s probably a Steam bug…


Yeah, I tried rebooting with kernel 5.12 and it seems like it only happens when Steam is running. My current theory is that it’s caused by Steam registering my pen tablet display as a controller, which I haven’t figured out how to make it stop doing (the only option in Steam is to hide controllers, not remove them).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.