Mouse cursor becoming invisible


It is a while since I have encountered this problem. The first time I noticed it was after a system upgrade of Manjaro. Basically, de cursor is becoming invisible (but still working) at random while working, I am not able to find any pattern that could be due to it. After a while, since I was thinking I could have done something wrong, I formatted everything and reinstalled Manjaro and Windows in dual-boot. In the beginning, this problem was not present but now it reappeared and I don’t know why.
The only thing that I have noticed, is that when it becomes invisible if I change the mouse input it becomes visible again, for instance, if I am working with the mouse and the problem shows I can move the cursor with the touchpad and the cursor becomes visible again (it is also the other way around).
This post “Mouse Cursor Disappearing” seems to be related, but I was not able to solve my problem.

Here are some details of my system:
Linux manjaro 5.9.16-1-MANJARO
x86_64 GNU/Linux
Processor: Intel® Core™ i5-6200U CPU @ 2.30GHz × 4
Graphics: Mesa Intel® HD Graphics 520 (SKL GT2)
Gnome Version: 3.38.4
Windowing System: Wayland

Thank you very much for your help!

Hi @Pop_B, and welcome!

I have absolutely no idea if this will work or not, but I see you are using Kernel 5.9 which is EOL. (End Of LIfe.) It’s recommended that you change to a supported one. Personally, I recommend either version 5.4 of 5.20 as they are the LTS versions, so they will be supported for longer.

To install 5.4, open a terminal and run,

sudo mhwd-kernel -i linux54

To install 5.10, open a terminal and run,

sudo mhwd-kernel -i linux510

If successful, reboot, and keep in your Shift key to bring up the grub bootloader screen.

From there, navigate to the “Advanced…” options, and select whichever kernel you just installed.

It should boot successfully.

Now it’s necessary to remove the previous kernel. To do so, open a terminal and run,

sudo mhwd-kernel -r linux59

That should remove the EOL kernel.

Once again, I don’t know if this will help with your other issue, but at least now you’ll have an updated kernel, which is important.

1 Like

Thank you vary much for your reply!

I didn’t notice that my current kernel is marked as EOL. Actually I was assuming that with a fresh install of Manjaro the kernel installed should be an updated one. But I will update it immediately.

However I have already tried to update and change my kernel before reinstalling Manjaro and the problem was still there, independently from the kernel in use. So probably the problem is elsewhere.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  3. Which kernel versions did you try already?

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

Thank you for your reply! I hereby attach the required information:

  Kernel: 5.10.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=4194959b-0377-4c58-bb34-d1a88298ef8c ro quiet 
  resume=UUID=005199e6-4048-4dad-99e9-e893dbd5dec7 udev.log_priority=3 
  Desktop: GNOME 3.38.3 tk: GTK 3.24.26 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Convertible System: HP product: HP Spectre x360 Convertible PC v: N/A 
  serial: <filter> Chassis: type: 31 serial: <filter> 
  Mobo: HP model: 804E v: 33.24 serial: <filter> UEFI: American Megatrends 
  v: F.53 date: 07/01/2019 
  ID-1: BAT0 charge: 49.2 Wh (100.0%) condition: 49.2/49.2 Wh (100.0%) 
  volts: 12.8 min: 11.4 model: Hewlett-Packard Primary type: Li-ion 
  serial: N/A status: Full 
  RAM: total: 7.69 GiB used: 4.45 GiB (57.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP 
  arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: E2 cache: 
  L2: 3 MiB bogomips: 19204 
  Speed: 2630 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2630 2: 2630 
  3: 2629 4: 2679 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Hewlett-Packard 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300 
  Device-2: Sunplus Innovation HP Truevision Full HD type: USB 
  driver: uvcvideo bus-ID: 1-6:3 chip-ID: 1bcf:2c7d class-ID: 0e02 
  Display: wayland server: 1.20.10 compositor: gnome-shell driver: 
  loaded: i915 note: n/a (using device driver) - try sudo/root display-ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d70 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.19-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.22 running: yes 
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: f040 
  bus-ID: 02:00.0 chip-ID: 8086:095a class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: virbr0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-7:4 chip-ID: 8087:0a2a class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Message: No RAID data was found. 
  Local Storage: total: 238.47 GiB used: 38.07 GiB (16.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD7SN6S-256G-1006 
  size: 238.47 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 1006 scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw-size: 100 GiB size: 97.93 GiB (97.93%) used: 38.07 GiB (38.9%) 
  fs: ext4 dev: /dev/sda6 maj-min: 8:6 label: N/A 
  uuid: 4194959b-0377-4c58-bb34-d1a88298ef8c 
  ID-2: /boot/efi raw-size: 512.1 MiB size: 511.1 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda5 maj-min: 8:5 label: N/A 
  uuid: 948D-A4A7 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 10.5 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda8 maj-min: 8:8 label: N/A 
  uuid: 005199e6-4048-4dad-99e9-e893dbd5dec7 
  ID-1: /dev/sda1 maj-min: 8:1 size: 100 MiB fs: vfat label: N/A 
  uuid: CE5A-4690 
  ID-2: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/sda3 maj-min: 8:3 size: 47.86 GiB fs: ntfs label: N/A 
  uuid: B25C5E8D5C5E4BEB 
  ID-4: /dev/sda4 maj-min: 8:4 size: 507 MiB fs: ntfs label: N/A 
  uuid: C87C460E7C45F828 
  ID-5: /dev/sda7 maj-min: 8:7 size: 79 GiB fs: ntfs label: N/A 
  uuid: 583CDE2D58064EF4 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-4:2 info: Integrated Express ITE Device(8350) type: HID 
  driver: hid-sensor-hub,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 048d:8350 class-ID: 0300 
  Device-2: 1-6:3 info: Sunplus Innovation HP Truevision Full HD type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 1bcf:2c7d class-ID: 0e02 
  Device-3: 1-7:4 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Device-4: 1-8:10 info: Elan Micro Touchscreen type: HID 
  driver: hid-multitouch,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 04f3:2070 class-ID: 0300 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 39.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 219 Uptime: 20m wakeups: 1 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 Packages: pacman: 1323 lib: 400 flatpak: 0 Shell: Zsh 
  v: 5.8 running-in: guake inxi: 3.3.02 

I tried different kernels, these are those that I am sure of 5.9, 5.10 and 5.11
I have tried also an older one but I don’t remember the exact version, I am sorry.

I will update also my profile, thank you for the tips :slight_smile:

Then I can’t help you any further because I’m on KDE and Xorg, whereas you’re on Gnome and Wayland…


Thank you anyway!
Do you know where else I can search for an answer to my problem? It is literally making me crazy to work with a cursor that disappears every 30 seconds :face_with_head_bandage:

Hello everybody, I still have the issue and I think that I found what could cause the problem, but I don’t know how to go further.

Basically I noticed that the issue appeared with an update of Manjaro and I think that highly probably the problem is related to the fact that Gnome now runs on Wayland and not on Xorg anymore. I suppose that this is the issue, but I really don’t know much about Display Servers, so if you can help me it will be really appreciated!

I am also seeing this with an older iMac with XFCE.
Trying the xorgconf “fixes” results in a black screen, so I have to reboot from USB stick and remove the files. [xorg.conf.d/90-mhwd.conf or 99*conf].
Updated system, so driver regression suspected.
Any help appreciated.

Hi, I think I had a similar issue, that drove me crazy for days. At the end the cursor theme caused the problem… In tweaks I switched to awaita cursor theme.

1 Like

Thank you for the information, I tried your solution, but the problem is still present.
Thank you anyway!

1 Like