Mouse Constantly Drifts Left

I just ran a system update, rebooted, and now the mouse is constantly moving slowly to left.
I did some searching but can’t find any reference to similar issues.

Anyone have any ideas what’s going on?

  Host: richard-desktop Kernel: 6.1.64-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.9 Distro: Manjaro Linux
  Type: Desktop System: Gigabyte product: B550I AORUS PRO AX v: N/A
    serial: N/A
  Mobo: Gigabyte model: B550I AORUS PRO AX v: x.x serial: N/A BIOS: American
    Megatrends LLC. v: FA date: 11/30/2022
  Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 2600 min/max: 2200/4850 cores: 1: 2200 2: 2200 3: 2200
    4: 2200 5: 2200 6: 3800 7: 2200 8: 2200 9: 2200 10: 3800 11: 2200 12: 3800
    13: 3800 14: 2200 15: 2200 16: 2200
  Device-1: NVIDIA GA104 [GeForce RTX 3060] driver: nvidia v: 545.29.06
  Device-2: KYE Systems (Mouse Systems) PC-LM1E Camera
    driver: snd-usb-audio,uvcvideo type: USB
  Display: server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2 driver: X:
    loaded: nvidia gpu: nvidia resolution: 5120x1440~120Hz
  API: EGL v: 1.5 drivers: nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
  API: Vulkan v: 1.3.269 drivers: nvidia surfaces: xcb,xlib
  Device-1: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Razer USA BlackShark V2 Pro
    driver: hid-generic,snd-usb-audio,usbhid type: USB
  Device-4: KYE Systems (Mouse Systems) PC-LM1E Camera
    driver: snd-usb-audio,uvcvideo type: USB
  Device-5: Plantronics Plantronics Blackwire 3225 Series
    driver: plantronics,snd-usb-audio,usbhid type: USB
  Device-6: Sony DualSense wireless controller (PS5) driver: usbfs type: USB
  API: ALSA v: k6.1.64-1-MANJARO status: kernel-api
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 74:56:3c:6d:14:ac
  Device-2: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e
  IF: wlp5s0 state: down mac: 82:49:b3:63:2b:f3
  Device-3: Sony DualSense wireless controller (PS5) driver: usbfs type: USB
  Device-1: MediaTek Wireless_Device driver: btusb type: USB
  Report: hciconfig ID: hci1 state: up address: BC:F4:D4:0D:45:2C bt-v: 5.2
  Device-2: Broadcom BCM20702A0 Bluetooth 4.0 driver: btusb type: USB
  Report: ID: hci0 state: up address: 5C:F3:70:A6:7A:16 bt-v: 4.0
  Local Storage: total: 3.17 TiB used: 2.16 TiB (68.3%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T2B0C
    size: 931.51 GiB
  ID-2: /dev/sda vendor: SanDisk model: SDSSDHII480G size: 447.13 GiB
  ID-3: /dev/sdb vendor: Crucial model: CT2000MX500SSD1 size: 1.82 TiB
  ID-1: / size: 287.31 GiB used: 71.86 GiB (25.0%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /home size: 1.7 TiB used: 1.61 TiB (94.7%) fs: ext4 dev: /dev/sdb3
  Alert: No swap data was found.
  System Temperatures: cpu: 74.4 C mobo: 44.0 C
  Fan Speeds (rpm): fan-1: 1178
  Processes: 380 Uptime: 25m Memory: total: 64 GiB available: 62.72 GiB
  used: 27.64 GiB (44.1%) Shell: Sudo inxi: 3.3.31

Silly question, have you tried another mouse?
Could have just been a coincidence it broke right after an update.

I haven’t. It was literally “working, reboot, 15 seconds later, not working”. That would be a hell of a coincidence.

I unplugged the mouse, and the cursor is still moving so there’s not any aberrant signals from the hardware.

If you have btrfs and snapshots I recommend restoring to before the update and retry. Or you could try to recompile your kernels with sudo mkinitcpio -P and reboot to see if something strange just happened in the creation of the kernels.

Not on btrfs.

Is that all that’s involved in recompiling the kernel? Not done it before and figured it would be harder than that! :smiley:

ASSUMING your download of all updated things went through correctly, yes.

If I’m not back in 10 minutes, it’s all your fault. :rofl:

That’s not what that command does…

See: man mkinitcpio and mkinitcpio - ArchWiki

mkinitcpio - Create an initial ramdisk environment

      -P, --allpresets
           Process all presets contained in /etc/mkinitcpio.d. See the -p
           option for more detail about presets.

You mean it does more?

Please explain, I hate dislike giving out wrong information. :slight_smile:

Thanks for the info @Yochanan

Either way @bedna, it didn’t help. However, I have fixed it. On reboot I noticed that the mouse cursor was stationary on the login screen, and immediately after login. This prompted me to look at the programs that were starting automatically.

Somehow SC-Controller had got itself back into my auto-start list and it was that causing the mouse drift. Removed it from the auto-start, rebooted, and voila. Problem solved.

Thanks for the sounding board.

You have spooky gremlins in your system… Happens sometimes. xD


How? I bet it was because…


No, it does less. :wink:

I just mentioned the man page and wiki article. :wink:

Either way, that’s a subject for another topic as it’s not related to this one…

Feel free to discuss here. I’m interested too.

Let’s not and say we didn’t.

Shot fired, point taken.
:innocent: :smiling_face_with_three_hearts: :kissing_closed_eyes:

But @Yochanan the solution was actually:

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.