Mouse and touchpad have very different scroll speed on Firefox on Wayland

As the title says, the scroll speed I get when using the touchpad or the external mouse (a Razer Basilisk V3) are very different, but this happens only in Firefox (i.e. it doesn’t happen in other apps like Nautilus, Libreoffice, etc.) and it happens only when Firefox runs natively on Wayland (i.e. it doesn’t happen when Firefox is run using XWayland, already tested).

I don’t have much of a clue on how to troubleshoot this. The workaround I’m using is changing the value of mousewheel.default.delta_multiplier_y in about:config, but changing it everytime I plug/unplug the mouse is far from ideal.

Any ideas?

Hi @MattG,

Perhaps this helps some:

Also see:

Thanks. As regards the first suggestion, since the touchpad works fine I wouldn’t change anything related to it. Regarding the second, it’s more promising but a bit complex, and the script would need to run automatically detecting whether the mouse is connected or not…

Thanks for providing these suggestions!

1 Like

I believe this can be accomplished using a udev rule.

See here:

Firefox on Wayland has kinetic scrolling on by default. To disable it, open about:config, search for apz.gtk.kinetic_scroll.enabled, and set it to false .

I changed it but it didn’t affect the behaviour I described in my first post.



Never mind, got carried away


  • GNOME manages mouse acceleration by itself. A choice between “adaptive” and “flat” profiles can be chosen by installing dconf-editor and editing the value in org/gnome/desktop/peripherals/mouse/acceleration-profile. Alternatively, gnome-tweaks can also be used to edit the org/gnome/desktop/peripherals/mouse/acceleration-profile.

Mouse acceleration - ArchWiki

Edit #2:

Fair warning: I don’t use Gnome, so this might work or it might not.

Please provide the output of:

gsettings list-keys org.gnome.desktop.peripherals

…both while the mouse is connected and not.

The mouse works fine with every app except Firefox as I explained at the beginning. I have configured the mouse and I would not mess with system configuration…

Regarding the command gsettings list-keys org.gnome.desktop.peripherals, it doesn’t give any output either with the mouse connected or with the mouse not connected.

I guess for now using Firefox with XWayland is the safest workaround…

The udev script that changes about:config is a bit complex for me, I think – or at least, I don’t have time to try it right now. I’ll get back to it if necessary when I have more time.

1 Like