Mousai refuse to start

I tried to use that little program recently. While it wasn’t working exactly before, this update make it not even start.
Traceback (most recent call last):
File “/usr/bin/mousai”, line 30, in
from mousai import main
File “/usr/share/mousai/mousai/”, line 18, in
class Application(Adw.Application):
File “/usr/lib/python3.9/site-packages/gi/”, line 123, in getattr
raise AttributeError("%r object has no attribute %r" % (
AttributeError: ‘gi.repository.Adw’ object has no attribute ‘Application’"

Some programs need rebuild after a system update, especially AUR packages … so:
pamac build mousai

Also, it might be related Mousai not work with meson build · Issue #22 · SeaDve/Mousai · GitHub

1 Like

As of mousai 0.5.1, it only works with libadwaita-git. What version do you have installed?

The rebuild produce the same error as mentioned. The “libadwaita-git” is the one from the repo 1:r1596a65ac525-1.

Which repo? It’s in the AUR (Arch User Repository).

That’s not a valid pkgver. If you installed it from the AUR, the current version is 1.0.0+alpha.2+57+g1942480-1.

Well of course it is coming from the pamac AUR list. That’s the number I see. That’s the only one there. How can I see what version from the command line ?

Ok had a look at the construction file and found this : pkgver=1.0.0+alpha.2+3+g959f434

The version in the PKGBUILD is not the version you have installed.

pamac info libadwaita-git

well this command give me as version number, the one I gave you (1:r1596…)

On the Add/Remove Software (Pamac) Preferences > Third Party tab, do you have Check for updates and Check for development packages updates checked?

Either way you need to rebuild the package to pull the latest commit:

pamac build libadwaita-git

I had the first one ON but not the second one. It is not set by default I guess. Anyway I rebuild it as you suggest and this time, it got your version. So the build file in pamac is wrong ?
Now mousai start fine however it is not picking up my microphone, complaining “No audio detected”. I check and my mic is working in the audio mixer. Well that’s another thing I guess …

No, it’s a VCS package. It will always build from the latest commit. The PKGBUILD does not need to be updated unless a change needs to be made.

Ok lets pretend I am a Linux expert and I understand your last sentence. Hopefully everything will be straighten up for the next truck driver like me.

Let’s not. If you don’t understand something, ask a question. :wink:

Remember, using the AUR is technically not supported by Manjaro or Arch and is your own responsibility to maintain those packages.

See for further study:

Also, libadwaita is still an an Alpha state and may be unstable no matter what package you use. It should be more stable for the GNOME 41 release this Fall.

1 Like

Thanks but I am sure I will anger Manjaro fans but I tried mousai in Linux Mint, my second bootable OS and it works the first shot perfectly. So the program itself works fine. It seems to be poorly ported in Arch/Manjaro at the moment.

P.S I have no interest in taking a course in the AUR system. Remember, I am just a truck driver.

There is no package for Debian based distros. I’m guessing you installed the Flatpak which is the only supported release by the Mousai developer. You can also install the Flatpak in Manjaro:

flatpak install flathub io.github.seadve.Mousai

Add/Remove Software (Pamac) has Flatpak support, you can enable it on the Third Party tab under Preferences.

Then don’t use the AUR.

You say that like it’s a lowly position. If truck drivers went on strike, the whole economy would stop and chaos would ensue. Your job is very valuable. Thank you for your service!

1 Like

Yes it was a flatpak in Mint. The flatpak version in Manjaro doesn’t work like I mention. Unlike Mint, even though my logitech cam mic is detected fine by Manjaro, mousai doesn’t detect it and says no audio detected. So it doesn’t work.

So if you don’t want to learn how your car engine work, don’t drive. Brilliant ! Obviously, you didn’t understand the truck driver allusion, it is pretty rare to find truck drivers use Linux nothing to do with intelligence. You spend too much time on your computer. Get out a bit :stuck_out_tongue_winking_eye: