Mounting LUKS partition suddenly requires double authentication


My Manjaro KDE machine has an internal partition that is LUKS encrypted. I have the password saved in the KDE Wallet. To open this partition, I click on it in Dolphin, a password prompt with the password already filled in comes up and I just need to click ok. So far so good. This is with SATA Hot Plugging enabled in my BIOS, which is the default setting, and also the setting that was on when I installed Manjaro.

After I disable Hot Plugging, mounting the LUKS drive requires a second step. After the LUKS password prompt, there is a sudo prompt.

This is reversible; enabling hot plugging in the BIOS again removes the sudo prompt.

I’d prefer hot plugging off, because when it is on, KDE recognizes all internal drives as removable drives. Is there a way to get rid of the sudo prompt in that case? Thanks :slight_smile:

You could create a polkit rule as described here:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.