Mount with NTFS3 fails with 5.15.2 kernel

Hi, I heard that Manjaro officially supports NTFS3 as of 5.15.2 kernel.
But it still fails to mount with the NTFS3 driver on my system, and here’s my setting in /etc/fstab

UUID=069AEF0E7015C576			  /media/1T-HDD  ntfs3    defaults,uid=1000,gid=1000,dmask=027,fmask=137 0 0

I’ve tried a number of combinations for the options, but it keeps throwing the error message mount: /media/1T-HDD: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.

Also, I’m 100% sure I’m running with 5.15.2 kernel, as mhwd-kernel -li gives me

Currently running: 5.15.2-2-MANJARO (linux515)
The following kernels are installed in your system:
   * linux514
   * linux515

How can I fix this and get rid of the crappy FUSE driver?

Check if other options help, make sure the partition is not hold from Windows (Fast Startup should be switched off). I’m not sure if dmask and fmask are supported for ntfs3. Check the integrity of the partition from Windows as well. ntfs-3g and ntfs3 do play well together, no need to remove ntfs-3g.


Wow, it seems to be related to those Fast Startup stuff. (This disk is originally used on a Windows machine.)
I plugged in another disk, formatted it as NTFS and the mount succeeded now.
As I don’t have access to Windows right now, I’m gonna backup the files, format it and see if the problem gets solved.
Thanks for the advice!


Documentation here linux-ntfs3/ntfs3.rst at master · Paragon-Software-Group/linux-ntfs3 · GitHub

Maybe could work with

   * - force
     - Forces the driver to mount partitions even if volume is marked dirty.
       Not recommended for use.

but as mentioned, not recomended.