Mount: /openswap_keymount: no filesystem type specified

Hello everyone,

I’ve been running Manjaro with the XFCE flavour for over 3 years now. And I’ve been puzzled with this problem. I can’t seem to boot into my OS anymore.

I’ve been running a dual boot where I’ve installed each OS on a different SSD. However, it seems if my NVME SSD isn’t being recognised anymore. Both of my drives are encrypted.

The windows with Bitlocker and the Manjaro with LUKS. This is the error message I’m getting after selecting to boot into Manjaro from GRUB

mount: /openswap_keymount: no filesystem type specified.
Device /dev/disk/by-uuid/3f65[...] does not exist or access denied.
umount: can't unmount openswap_keymount: Invalid argument
ERROR: resume: hibernation device ` /dev/mapper/luks-3766[...]` not found
mount: /new_root: no filesystem type specified.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off
[rootfs ]#

I then created the current Manjaro XFCE iso and booted into it (I’m currently using it to write this post).
I’ve then tried running: lsblk -f
This is the output from the command:

NAME   FSTYPE    FSVER            LABEL             UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0  squashfs  4.0                                                                           0   100% /run/miso/sfs/livefs
loop1  squashfs  4.0                                                                           0   100% /run/miso/sfs/mhwdfs
loop2  squashfs  4.0                                                                           0   100% /run/miso/sfs/desktopfs
loop3  squashfs  4.0                                                                           0   100% /run/miso/sfs/rootfs
├─sda1 vfat      FAT32                              3877-E820                                           
├─sda3 BitLocker 2                                                                                      
└─sda4 ntfs                                         A09AF6D39AF6A546                                    
sdb    iso9660   Joliet Extension MANJARO_XFCE_2204 2023-02-22-07-03-31-00                     0   100% /run/miso/bootmnt
├─sdb1 iso9660   Joliet Extension MANJARO_XFCE_2204 2023-02-22-07-03-31-00                              
└─sdb2 vfat      FAT12            MISO_EFI          6E2E-A045                                           

I don’t seem to find my NVMe where I have Manjaro installed on it?
When i try running inxi --full I get the following output:

  Host: manjaro Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 Desktop: Xfce
    v: 4.18.1 Distro: Manjaro Linux
  Type: Laptop System: Dell product: Vostro 5481 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0D99JV v: A00 serial: <superuser required> UEFI: Dell
    v: 2.4.0 date: 07/02/2019
  ID-1: BAT0 charge: 24.0 Wh (100.0%) condition: 24.0/42.0 Wh (57.1%)
  Info: quad core model: Intel Core i5-8265U bits: 64 type: MT MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 2577 min/max: 400/3900 cores: 1: 1715 2: 3030 3: 1800
    4: 1800 5: 3060 6: 3028 7: 3098 8: 3091
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] driver: i915 v: kernel
  Device-2: NVIDIA GM108M [GeForce MX130] driver: nvidia v: 525.89.02
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: modesetting,nvidia
    dri: iris gpu: i915 resolution: 1920x1080~60Hz
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel Cannon Point-LP High Definition Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
  IF: wlo1 state: up mac: f4:d1:08:ac:78:5d
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: down mac: 6c:2b:59:50:39:d1
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
  Local Storage: total: 240.39 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
  ID-2: /dev/sdb type: USB vendor: Silicon Motion model: USB size: 7.5 GiB
  Message: No partition data found.
  Alert: No swap data was found.
  System Temperatures: cpu: 51.0 C pch: 49.0 C mobo: 51.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 248 Uptime: 56m Memory: 15.32 GiB used: 4.32 GiB (28.2%)
  Shell: Bash inxi: 3.3.25

Again, upon further inspection I can see that in the Drives section, only one of the two SSDs is displayed (NVMe is missing).

I’m not so experienced with Linux that I can continue debugging this on my own and coming up with a solution. My hunch is, that somehow for whatever reason the NVMe isn’t being detected…?

It was working fine yesterday, the only thing i can remember is when I updated pacman -Syu it installed spectre meltdown checker I believe that’s how that package was named. Not sure if this is relevant whatsoever?

As this is my work box, I really don’t want to opt to the reinstall solution yet.

Thanks in advance.

I found that when I run the command:

[manjaro /]# dmesg | grep -i nvme
[    4.142532] ahci 0000:00:17.0: Found 1 remapped NVMe devices.

I’m not sure what that might mean. But that does lead me a step closer to identifying the root cause of the issue (at least that’s what I believe…)

Did you try booting with a 5.x kernel yet?
It might be related to some drivers or modules, maybe :thinking:

Also are both NVMe drives listed in your UEFI-BIOS?
You need to enter your BIOS for that…


Did you try booting with a 5.x kernel yet?

I tried booting with 5.10 as the kernel. Same problem.

The Kernel: 6.1.12-1-MANJARO Is from the live usb.

Also are both NVMe drives listed in your UEFI-BIOS?

I’ve got a Samsung SSD and a Toshiba NVME. This is the BIOS output:

SATA-0 = 250GB S3YJ...
SATA-2 = (none)
M.2 PCIe SSD-0 = 256 GB 98MPA0....

They’re both showing up in my BIOS entry.

However! If I’m inside of the GRUB CLI by pressing C in the GRUB menu. I enter the GRUB CLI.

When i use the ls command I get both of the drives displayed. And I can navigate inside of my filesystem…

This is the output I get when I’m inside of the GNU GRUB version 2.04~Manjaro prompt

grub> ls
(crypto0) (proc) (hd0) (hd0)  (hd0,gpt3) (hd0,gpt2) (hd0,gpt1) (hd1) (hd1,gpt4) (hd1,gpt3) (hd1,gpt2) (hd1,gpt1)
grub> _ 

Please excuse the image quality, : :grimacing:
Here’s also an image from the failed boot

Here the GRUB Config:

And finally the GRUB CLI output when i try to use ls

I was able to resolve the issue.

Somehow my BIOS decided to change my SATA operation to RAID ON from AHCI. Due to this, the NVMe SSD wasn’t being read during load, which meant the path to the LUKS container wasn’t there.
Props to this post for nudging me in that direction:
LUKS encrypted drive is missing. “cryptsetup: lvm is not available”

Hopefully this might help someone else encountering this issue in the future :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.