Mount: /new_root: can't find <device_uuid>

Hello everyone, I hope you’ll be able to help me.

When I boot on my fresh manjaro gnome installation I get this error during boot

ERROR: device ‘UUID=<device_uuid>’ not found. Skipping fsck mount: /new_root: can't find <device_uuid>. You are now being dropped into an emergency shell. sh: can't access tty: job control turned off

Prior to that I checked the existing forum posts on this topic.
I used the Live USB to chroot in the existing manjaro system, then I compare the UUID between the chrooted system /etc/fstab and compare it to the Live USB lsblk -fs and the UUIDs matches.

I also tried to reboot use fail-safe default options in boot, ensure it doesn’t use AHCI (which always throw ‘read errors’ whatever system or HDD/SSD I use) nor RAID but rather IDE mode.

I don’t have VMD on this bios nor boot protection for Windows.

I tried in the chrooted environment to do an update-grub which was successful, still having correct UUIDs, but not success in booting.

Checking the command sudo dmesg --level emerg,alert,crit,err,warn there’s some interesting lines in beginning related to overlayfs, impi_si, acpi, lpc_ich

[    0.145136] ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
[    4.166832] r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    7.158655] overlayfs: null uuid detected in lower fs '/', falling back to xino=off,index=off,nfs_export=off.
[    8.842838] ipmi_si: Unable to find any System Interface(s)
[    8.961904] spl: loading out-of-tree module taints kernel.
[    8.973716] znvpair: module license 'CDDL' taints kernel.
[    8.973719] Disabling lock debugging due to kernel taint
[    9.245646] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x000000000000042C-0x000000000000042D (\GP2C) (20210730/utaddress-204)
[    9.245675] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   16.952281] kauditd_printk_skb: 17 callbacks suppressed
[   22.025196] kauditd_printk_skb: 12 callbacks suppressed

[   60.653475] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  470.86  Tue Oct 26 21:55:45 UTC 2021
[   60.721349] kauditd_printk_skb: 19 callbacks suppressed
[   61.232720] resource sanity check: requesting [mem 0x000e0000-0x000fffff], which spans more than pnp 00:08 [mem 0x000e0000-0x000effff]
[   61.232727] caller _nv033181rm+0x2a/0x60 [nvidia] mapping multiple BARs
[   61.353853] resource sanity check: requesting [mem 0x000c0000-0x000fffff], which spans more than PCI Bus 0000:00 [mem 0x000c0000-0x000dffff window]
[   61.353856] caller _nv000722rm+0x1ad/0x200 [nvidia] mapping multiple BARs
[   65.800814] kauditd_printk_skb: 21 callbacks suppressed
[   68.589151] nvidia_uvm: module uses symbols from proprietary module nvidia, inheriting taint.
[   81.041691] kauditd_printk_skb: 11 callbacks suppressed
[  126.024574] kauditd_printk_skb: 2 callbacks suppressed

Also there are no entries in the journal of the chrooted system.

See if this helps… :arrow_down:

I already did the grub part rewriting checking for UUIDs but not this part with mkinitcpio

mkinitcpio -P

I’m gonna try after and I’ll tell if it helps.

Yes, it worked thanks to the mkinitcpio -P and it booted instantly on Gnome so fast, thank you! You’re my savior! :grinning:

P.S: It makes me wonder why it worked smoothly with the Live USB chroot using this command and not with the installer (I did 6 installs in a row before). I’m sure your help might be useful for the installer.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.