Mount Error - Filetype APFS not configured in Kernel

I have MBP 2012, in which I have installed Manjaro Gnome DE. It has dual OS, the other is MacOS - High Sierra.

when I try to access the High Sierra drive (going to other locations) from Manjaro, It asks for Authorization and when I enter the correct Password, I get an error - " APFS file type not configured in Kernel".

Error mounting /dev/sda2/ at /run/media/lx/1d32bda4-6e3c-4783-b592-e5ee819701e1: Filesystem type apfs not configured in kernel.

I have installed the following Packages to my system without any issues, But still, when I access the High Sierra Drive, it errors out.

Linux-apfs-rw: APFS module for linux from Github.

Can you please suggest, how to fix this ?


You probably just cloned the repo and the actual build of the module failed because you have not installed the linux-headers for your running kernel (installed kernels).

My proposal is to enable AUR from Pamac UI and build AUR (en) - linux-apfs-rw-dkms-git
But first, you have to do some things for AUR packages. From terminal run:
sudo pacman -Syu base-devel --needed

Then you install the linux headers for your installed kernels. This command will install automatically (in case you have more than one kernel installed):

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

Then you build the package:
pamac build linux-apfs-rw-dkms-git
it will automatically install dkms too … reboot after that and check if you can mount and access the apfs drive.
You might also need the tools later, so you will have to build AUR (en) - apfsprogs-git

1 Like


Thank you Bogdan for the reply, I have reinstalled the linux-headers, using the command you have provided. In my system, I already have the base-devel

I have installed the following package using

$ yay -S linux-apfs-rw-dkms-git
$ yay -S apfsprogs-git

Now, when I access the High Sierra Drive, I get a different error


Please Note:
I have 2 macOS partitions:

  • One is apfs file format - I am having issues in accessing (errors in this ticket).
  • The other is HFSplus - I can read this drive (even before installing all this) but as a read only mode.

You did reboot i guess. Also, what kernel do you use, maybe there are issues with some older/unsupported kernels.

Also, how do you mount the partition?

Best to mount as instructed on their project page GitHub - linux-apfs/linux-apfs-rw: APFS module for linux, with experimental write support and open an issue there, in case things don’t go accordingly.

Mounting via File Manager might not be supported yet, or maybe also Gnome Disks is not capable to do it.

Have you tried the recipes found on AUR?

The git repo you linked is represented as

Remember to clean your system for any previous attempt before trying other options as you may run into conflicts.

Hi Bogdan,

Yes, I did reboot the system. The kernel using in my system is Linux 6.1.21-1-MANJARO.
I have tried to mount it from terminal and also from the File Manager.

Sure, I will create a ticket in the Github - linux-apfs.


Can you show output of

cat /etc/fstab
ls -l /mnt

sudo mount -t apfs -o rw,force /dev/sda2 /mnt
mount: /mnt: … error message …

Possible fix:

sudo mkdir /mnt/shinynewsubdirname
sudo mount -t apfs -o rw,force /dev/sda2 /mnt/shinynewsubdirname/

Hi mishmosh,

I have tried the possible fix, but did not work.

any other suggestions, please ?

Here are the requested output of the commands:

$ cat /etc/fstab

$ mount

$ ls -l /mnt

Mount ls

dmesg(1) may have more information after failed mount system call.

Did you look?

… run:
sudo dmesg -w
in a terminal
while you try to mount - the command continuously logs the messages and you can see them appear in real time

journalctl -f
is another, similar way to glean more info

Please read the documentation on the project page i linked. Here a quick snippet

Make sure that from your mac system, you disable encryption … because teh documentation states:

Hi Bogdan,
Sorry for delay, I was out of station, travelling.
I have tried the command and I got error.

DMESG: output

Please do not post screenshots of text: user copy+paste and proper quoting.