Most monitors won't turn back on

I’m having a downright bizarre issue with my monitors under Manjaro that’s started after recent updates.

From a cold boot or a reboot, everything is perfectly fine and seems normal. However, after the computer goes to sleep and the screens are turned off, 2/3 of my monitors will not turn back on. The two that stay off are connected directly via Displayport, the one that turns back on just fine is connected via a Displayport->VGA adapter. Usually, either switching to a tty and back several times or toggling the display to disabled and back to enabled in settings will get it back on, but obviously I don’t want to need to do this.

The issue occurs on both the 5.7.17-2 Linux kernel and the 5.3.3-2 Linux kernel. It does not occur on Windows when dual booting. My kernel parameters in grub are “quiet apparmor=1 security=apparmor resume=UUID=d5c04289-a888-4279-abbd-f630feb55357 udev.log_priority=3 amdgpu.ppfeaturemask=0xffffffff immu=pt acpi_enforce_resources=lax”, though none of those were changed before this problem developed. Nothing was changed besides the update pushed by Manjaro stable.

I have a similar issue on my nephew’s PC with 5500 XT. The monitor connected via DP doesn’t wake up from suspend correctly. The system there is Pop OS with Liquorix kernel, Pop’s 5.4 behaves the same way, so I think we should try 5.8 and 5.9 to check if they are affected by this issue.

I’ve tested on the 5.8.3-2 kernel, calling it 5.3.3-2 in my post was a typo (same finger, opposite hand). I’ve not tried 5.9 yet, however.

The problem was nonexistent until one of the last two Manjaro updates. I’m not entirely sure which caused it as both were applied at once for me, but I never had any issues with my monitors before the two updates. So I’d been on kernel 5.7 with everything working perfectly for months.

1 Like

Hi,

I have the same issue with 5.8.3-2 after the latest update, in my situation my second display conected via DVI to my rx580 and wakes up but my main display (display port) does not, the fastest way to enable it back is turning it off then on again to reinitialize

Similar issues, only I experience a complete lockdown on my RX580 on Manjaro GNOME.

The issue began on one of the latest 5.7 updates, I switched to the 5.8.3-2 kernel which solved it up until today when I applied the latest update which just borked the OS completely.

What happens is that the screen will display only the latest still image which occurred when the monitored powered up. You can move the mouse around alright, but the rest of the screen absolutely does not react.

Turning monitor on and off will make it display the latest image once again, but will establish no actual usability.

CTRL + ALT + F3 opens the virtual shell but introduces a new problem. The screen displays the correct image for about 100ms then goes to black for about 200ms and repeats continuously.

I’m not sure who did the last few Linux Kernel/ Manjaro updates and where exactly the problem lies, but for me they have been an unmitigated disaster and have rendered my Manjaro OS distribution which I use for work completely unusable.

I’ll post the journalctl logs which caught the crash report tomorrow when I am able to access them.

I have a similar issue, RX 5700 XT with one monitor connected via Displayport. If I leave the xfce display settings to not configure new devices when connected the screen will go blank after 5 minutes for a few seconds before coming back, will never go to sleep. If I enable profiles and to configure new displays it’ll go black and stay black but will never come back on, have to reboot.

journalctl shows the following messages:

Sep 09 06:40:58 Manjaro kernel: [drm:dpcd_set_source_specific_data [amdgpu]] ERROR Error in DP aux read transaction, not writing source specific data
Sep 09 06:40:58 Manjaro kernel: [drm:retrieve_link_cap [amdgpu]] ERROR retrieve_link_cap: Read dpcd data failed.

The latest Manjaro update seems to have solved the problem for me. Unfortunately the update is far too large in scope for me to have any idea at all which change fixed the problem, but it seems to be fixed so that’s fine by me.

Hello, yep the last update fixed it for me too and the update it is indeed far to large to pinpoint the fixes

I’ve had similar problems, where I walked away from my PC, and when I came back the screen was blank. It appeared to shutoff the display, due to inactivity but I was unable to open a tty or anything. Also using a 5500 XT. Recent updates seemed to stabilise things.