Monitor unable to get sound through HDMI cable connected to ASUS NVIDIA GeForce GT 710 Video Card

I bought and installed the ASUS NVIDIA GeForce GT 710 Video Card after I found I could get no sound through the DVI cable.

I still get no sound.

The monitor is a 32 inch Philips BDM3201FD/75 2018 model. Hopefully the specs of the computer into which I am trying to install the video card can be found. I provided this information when I set up my account earlier tonight.

It is a DVI cable. If you want audio you should go for HDMI.

In fact, I had previously tried to connect to the DVI adapter on the motherboard and got no sound.

Now that I have plugged in to the HDMI connection on my new ASUS NVIDIA GeForce GT 710 Video Card, I still get no sound!

Can anyone suggest how I might diagnose this problem?

Please run inxi -Fazy and lspci -k.

Thank you, pobrn.

You will find all the output from both commands in one post at $ inxi -FazySystem: Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc - Pastebin.com

(I’m not sure why the above URL is not rendered like https_colon_slash_slash_pastebin_dot_com_slash_RdcK4A14 but it still seems to work.)

Could you please also run pa-info (when the HDMI display connected) and provide the output ?

Have done. The output is at: Output from pa-info - Pastebin.com

Strange. Everything seems OK and recognized. Can you run pavucontrol , go the the “output devices” tab and check if you can see the HDMI output?

Ok. So you are now using HDMI. You see a picture but no sound.

What about the sound settings of your desktop environment. You have 2 sound devices:

  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0e0f 

You need to tell your DE which device to use. There should be a sound configuration option in the system config section of your DE. There you need to select nvidia resp. HDMI as the outgoing device.

pavucontrol gives me:
First line: sound card icon, “Built-in Audio Digital Stereo (IEC958)”, speaker icon, faded lock icon, tick icon
Second line: Port: Digital Output (S/PIDF) - (no other option on drop-down menu.)
Third line: first 2/3 of horizontal line WAS blue. text says “100% (0.00) Db” twice
NOW third line is all colourless.

“Advanced” drop-down section: Only PCM is ticked. AC3, EAC3, DTS MPEG and AAAAC unticked.
Next line: Latency offset: 0.00
Next Line: sound card icon, "GK208 HDMI/DP Audio Controller Digital Stereo (HDMI), speaker icon, faded lock icon, tick icon.

I might call it a night, Thank you pobrn, mbod, and everyone else who has taken the trouble to read this.

(Maybe a reboot could fix the situation?)

That’s it. So the HDMI audio output is recognized. Open the system settings and try to select that as audio output device.

I couldn’t find where in “system settings” to “to select that as audio output device”.

Below, is my attempt, with text, to emulate a screenshot of pavucontrol (I trust that the administrators consider it sufficiently small for me not to have to post it to pastebin.com. )

Update 21:22 +10 Sun 20 Sep 2020

I have posted the “screen shot”, that was below, to text simulation of pulseAudio Volume Control screenshot - Pastebin.com where it is rendered somewhat better than here.

As I type this, the longer line, immediately below the line labelled “Front Right” is moving backwards and forwards as if in response to a news broadcast in one of my Firefox tabs, but there is no sound.

Which desktop environment do you use?

pobrn, I use the xfce desktop environment.

Maybe this helps?

You’re not suggesting I switch to Ubuntu to get sound on my Philips 32" monitor, pobrn?

Another workaround might be to try Arch Linux on which Manjaro is based.

Having looked at How do I switch to another audio output sink in XFCE? on askubuntu.com, I don’t understand the difference between xfce4-pulseaudio-plugin and pulseaudio. Both have been installed on my system, but there is only “Pulse Audio Volume Control” within the “Multimedia applications” branch of my menu. Is that one, the other or a combination of the two?

Previously, I could get sound on my Philips 32" monitor on an older computer with only 8G of RAM, but I am unable to get the sound to work on my newer computer with 16G of RAM.

No, I just sent a askubuntu.com question which has answers regarding where you can change the output sink using XFCE.

The amount of memory has not much to do with this.

PulseAudio is the sound server, xfce4-pulseaudio-plugin is an XFCE plugin that lets you control PulseAudio from XFCE.

Have you tried doing what is in the accepted answer?

  1. placing the pulseaudio plugin somewhere in the GUI (onto a panel, etc.)
  2. opening it to see if you can change the output sink (as shown in the screenshot)

You could also try the other answers, there are ones which only use pavucontrol.