Monitor suddenly not recognized anymore correctly (only 1024x768)

Hi all,

I have a strange issue concerning the recognition of my monitor. It’s a WQHD monitor from Dell (S2716DG) and it worked beautifully before, using HDMI, now, all of a sudden, it just allows 1024x768 resolution (or 800x600 from the good old days).

The issue manifested itself like this (long story):

  • Work laptop: It runs Windows 10. It worked well with the monitor, too, except for some hickups. When I let the monitor go into energy saver, sometimes it showed only 1024x768 too, but when I unplugged the HDMI, waited a bit, and plugged it in again, it was back to WQHD. Until a few days ago. Then it had this issue again, but I logged in first, before unplugging and since then my work laptop (a Dell too) only can set 1024x768 as the recommended (and highest) resolution on this monitor. So this Windows doesn’t recognize the monitor anymore correctly.

  • Private machine, Linux: I hoped the fresh machine would somehow reset the correct value again and I plugged the HDMI into my Manjaro machine, but here I am writing in a Manjaro forum, because it since then has the same issue. The max resolution that works is 1024x768. The highest that is offered at all is 1600x900, but that doesn’t work. xrandr (one of the tools that kept showing up in my internet searches) shows this:

➜  ~ xrandr --query
Screen 0: minimum 8 x 8, current 1024 x 768, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00*+
   1600x900      59.82  
   1400x900      59.88  
   1368x768      59.88    59.85  
   1280x800      59.91    59.81  
   1280x720      59.86    59.74  
   1024x576      59.90    59.82  
   960x540       59.82    59.63  
   864x486       59.92    59.57  
   800x600       72.19    60.32    56.25  
   800x450       59.82  
   700x450       59.88  
   684x384       59.88    59.85  
   640x480       59.94  
   640x400       59.98    59.88  
   640x360       59.86    59.83  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.82    59.63  
   432x243       59.92    59.57  
   400x300       72.19  
   320x240       60.05 

I became desperate and tried (sure why not) the Windows 10 installation on the very same computer with Manjaro.

  • Private Machine, Windows 10: Everything works as it should. Full WQHD resolution is available. No issues whatsoever.

I’m stumped. I don’t even know where I should start here.

I know that

  • the HDMI cable is intact (something that one reads when it comes to issues with monitors, too), because Win 10 has in 1 of 2 installations no issues.
  • the monitor itself works
    The issue occurs using 2 machines, but only on 2 of the 3 OS’s installed and unnervingly on 2 different ones.

I guess my question would be: How do I force Manjaro to get the information from the monitor’s plug&play functionality again and not rely what is stored? Somehow they talked and Linux (nor Windows) recheck that they actually are plugged to a 1024x768 device.

Kind regards,

Update: SOLVED.

This was solved finally in a capitalistic manner. I bought an adapter to link the HDMI out from the laptop and from my linux machine’s graphic card with the display port on the monitor. Both machines recognise the monitor as WQHD again (probably storing it as a “new device”?).

Before the adapter arrived I played a bit with the graphics card drivers and found that the NVIDIA driver was corrupted - when I uninstalled it and installed the open source drivers instead, it was WQHD, too. Installing the NVIDIA drivers again: same picture as before (1024x768).

I still do not know what happened here, I don’t know what broke the driver on the linux machine, because the incident was caused by my work laptop, but really forcing a new pnp detection (?) by plugging in DP instead of HDMI on my monitor seems to have done the trick.