Monitor is blinking as crazy [Intel CPU + Intel Iris XE + 1TB NVME SSD]

I have the following laptop: IdeaPad 5 Pro 14 [Intel CPU + Intel Iris XE + 1TB NVME SSD].

I installed the following version of Manjaro: [xfce + not minimal + 21.1.0].

I installed the system as is + applied updates. The screen is blinking sometimes when I do not move the mouse, and blinks a lot when I move the mouse.

I tried some different approaches to fix it:

  • installed KDE version. Blinked even more.
  • tried to switch display controller in “Manjaro Settings Manager”. Tried to switch to video-linux, video-modesting, video-vesa. Didn’t work, and also switching to video-vesa made the system fail to load.
  • tried to remove xf86-video-intel. Changed nothing.
  • tried to install LTS kernel. Did not help.

Can anyone help me to get rid off the blinking?

1 Like

You may need a custom display setting:

If that doesn’t help, please provide the basics:

I am making: xrandr --addmode DP1 2880x1800R
But it prints: xrandr: cannot find output “DP1”
How I need to guess the value to use instead of DP1?
Or what I am doing wrong?

OK, it was eDP-1 which is needed. Changed to 59.9 Hz. Blinks in the same way.

Also tried to run the lifecd of xubuntu and ubuntu. It also blinks.

Also: windows installer is not blinking. So screen is not broken, I guess.

I have exactly the same problem on my laptop: IdeaPad 5 Pro 16 [Intel CPU + Intel Iris XE + NVIDIA GeForce MX450 +1TB NVME SSD].

I don’t have a solution but I have something which might set you in the right direction. I am writing this from memory so the details might be wrong.

The live version of Fedora Gnome didn’t have the blinking. I think Ubuntu live “safe mode” also didn’t have the blinking. I believe the reason is the GRUB options includes nomodeset in the “linux = …” line .
I didn’t manage to get the Manjaro live version to start with nomodeset. I admit I didn’t try very hard and have little idea of how grub works.

The other thing of interest is that when the display was working correctly, the display setting showed a refresh rate of 75? Hz.
It was not what cvt -r predicted!

For the time being I’ve delayed installing linux on that laptop. I hope this helps. Please share if you find a solution.

Hey I solved it on my laptop with Iris XE graphic cards. I literally just created this account to help.

But I really want to complain cause I’m not allowed to put links in my replies.

just check out.

It’s related to the latest Iris XE.

Panel Self Refresh (PSR), a power saving feature used by Intel iGPUs is known to cause flickering in some instances [FS#49628] [FS#50605]. A temporary solution is to disable this feature using the [kernel parameter] i915.enable_psr=0 .

yeah they are old posts but seems like PSR bug appears on this new XE card. So we need to set some kernel parameter to fix it.

All you need to do is editing /etc/default/grub and adding i915.enable_psr=0 on GRUB_CMDLINE_LINUX_DEFAULT and type sudo update-grub then restart. Or if you prefer set it on grub menu. All good.

1 Like

This solved the flickering on my machine.
Thank you very much for the solution and for taking the time to create the account.