MoneyManagerEx AUR not working and Community version has been removed

I have been working with mmex (money manager ex) from few months ago. Now it’s not anymore in the community repo as this indicates:

I have tried to install it by AUR but application doesn’t starts with the error message:

std::bad alloc

If I try to launch it by terminal as “sudo mmex” it was working instead just “mmex” command, but now even with sudo says that.

I am thinking about installing it as a .deb but I am not sure if it would work as I am not linux experienced user.

I really need this program for working (I use it on Android as well with no issues)

Thank you all

If that is the error, then I would assume a problem with your RAM. It just cannot allocate space on the RAM because it is bad. In many cases, it just means: There no addressable space on the ram.

No space left?
No swap configured?
RAM is defect?

I can build and run mmex without any issues.

try using the build script from aur

pamac build moneymanagerex-git

Thanks for asking. I don’t think is because a defective RAM (I hope) as the computer is new and I have not gotten any problems with the RAM apart from this app…
I don’t know almost nothing about swap but when running “free” command I get this:

               total        used        free      shared  buff/cache   available
Mem:           15848        2491        9257        1163        4099       11861
Swap:            511           0         511

So I guess it’s configured, but it seems to be very little space maybe?

I already did it but no luck!.. thanks anyway

When you have tried everything in your power - then you move on to source - open an issue on the github repo.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.