ModemManager - Data connection

Does the recent switch to modemmanager help with cellular data connection on Manjaro/PlaMo?
I know it works really well with Phosh, but I like Plasma much more and cellular data connection is the only reason why I still have to use Phosh

In my experience the switch to ModemManager has made the modem connection much more stable.
It’s still not 100%, but it’s much better than before.

And is there someone working on making the cellular data connection working? :slight_smile:
Sadly, I’m not a dev that could do everything himself and I rely on work others do for free… (really appreciate it)

The data connection is working. The only issue is when the modem crashes and therefore disappears from the system, which is not something ModemManager can do much about, other than making sure it gets back online as soon as the modem shows up again.

Oh, that’s strange
I don’t remember data connection wokring with PlaMo at all
When I was using Manjaro PlaMo, I was trying to make it work using all oFono commands I could find (I probably don’t remember them correctly anymore but it was something like sudo ofonoctl --connect --append-dns)
And it can’t be a hardware issue 'cause I never use Wifi on my PP since data connection on Phosh works even better than connecting to WLAN

With ofono, I actually had to locate an undocumented config file and edit it to get it to connect to mobile data successfully. Otherwise, it would insist on using DEFAULT as the APN, which does not work with the operator I am using. And the Plasma Mobile settings were unable to change any settings, it only worked when editing it directly in the config file. And then, I also had to configure NetworkManager to not automatically connect to DEFAULT using the desktop kcmshell5 kcm_networkmanagement (and no, deleting the connection entirely does not work because it will be recreated each time, only turning off the auto-reconnection works). But then I had mobile data working.

With ModemManager, I need none of the above, it just works, but now the issue is that disabling mobile data breaks things, see Disabling WWAN completely disables PinePhone modem (with ModemManager) (#880) · Issues · NetworkManager / NetworkManager · GitLab.

The data connection works great on Plasma now but it keeps losing connection. Apparently per previous comment this connection issue is a modem crash but I don’t have that issue on Phosh. The reason I am using Plasmamo instead of Phosh is that in Phosh no matter what I do I cant get MMS working properly. But I am hoping these issues get resolved soon as it just seems like a month ago I wasn’t able to place outbound calls in either version or do MMS or get data working in Plasmamo. So the devs are doing great work. I am hoping the Devs can figure out this dropped connectivity issue on Plasmamo because that seems like the only thing from holding me back from this being a daily driver. I am using Mintmobile BTW.

Yeah, I use phosh just because PlaMo is too unstable for me, and because Phosh “just works” without any tricks and tweaking - Data connection has no problems whatsoever (ok, sometimes I lose connection for a couple of seconds but it reconnects immediately, so it doesn’t bother me and most of the time I don’t even notice)

I did actually get MMS nd SMS working on Phosh and my Pinephone works great with Mintmobile.

For an update I did get Phosh working with SMS/MMS It wasnt that hard. I am looking for future updates to PlasmaMo but for now Phosh works perfectly.