Modem not showing up

I’ve been happily daily-driving my PinePhone for the past year and about a month and a half ago (when Pine64 posted their June Update talking about it) I flashed the community firmware, because it looked like a good thing to do
It had been working well for about a month, it was just a bit less stable, however, nothing to be mad about.
Then I went on a hike to Bulgaria and as soon as I left the Czech Republic (where I live), the modem became very unstable - it couldn’t be detected half the time. I have no idea whether that was caused by the new firmware, different operator or something absolutely different.
When I was in Bulgaria (without a PC or a laptop and a free microSD card), I updated my OS on a free wifi and I encountered a freezing issue with Phosh ([ARM Stable Update] 2022-08-03 - Firefox, KDE Gear, Code and Kernels - #22 by lgtrombetta), leaving me with a half-usable OS and my modem nearly stopped showing up (it still did show up sometimes)
Even though I’m back home and I reflashed the OS and fixed all the issues, my modem doesn’t show up regardless of the position of the DIP switches, so I can’t call, text, use data, nor can I flash older firmware and then reflash the new one because in order for that to work, the modem has to show up and stay that way through the flashing process …
Do you have any troubleshooting advice or knowledge to share? I would love to see my PinePhone working properly again :cry:

Have you tried removing the sim card before attempting to reflash the modem firmware? I found the flashing process to be much more stable this way.

Right now I have my SIM card in an old Nokia and I’m waiting for the modem to show up so that I can try to flash the new 0.6.8 firmware …

Tried it a couple times when it showed up, however, it always disconnected during the process of flashing the firmware.
Any ideas what I can try next?

So it doesn’t work nor show up at all.
I’m thinking of getting a new mainboard in which case I’d be interested in using the old one board as an SBC. Has anyone tried it? Is it possible/usable? :wink:

The modem hasn’t been enabled regardless of firmware for months now. You always need to enable it manually via “mmcli” after you started the phone.

I don’t the thread I got them from handy. And I also cannot get the command from the bash history since the latest updates completely broke the phone.

The original issue in this thread (@Muskwa’s issue) sounds fairly similar to what I am experiencing right now: PinePhone modem keeps "disappearing" (Pine64 forum).

Unfortunately, I do not have a solution either. Seems to be a hardware fault (and apparently a relatively uncommon one).

@Firewave’s issue, on the other hand, sounds different, because the modem is still responding to mmcli. Mine does not show up on mmcli at all when it disappears.

FYI The modem is unavailable for a brief time after entering the PIN and mmcli reports error: couldn't find modem.

Try to boot the modem into EDL mode and see if it shows up. Then flash stock firmware 006.

I’ve been inactive for quite a while.
The problem with my PinePhone was a faulty modem. It died while I was travelling (you know, it has to switch towers rly fast and that was its last breath).
Same as @Kevin_Kofler experienced (see the link to Pine64 forums they posted here), USB connection is broken as well
I can both say I’m sorry for wasting everyone’s time and I can say that everyone with similar issues should maybe investigate their hardware further :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.