Mobile data not working

On a new pinephone mobile data is not working
Apn settings is grey out

This usually indicates that the SIM card was not detected. Please try re-inserting it.

But I can make phone calls

Hm. Please post a screenshot of the screen found in Settings → Cellular Network → SIM 1 → Mobile APN’s.

When you go to Cellular, you need to put in your password, not your SIM PIN.

I put t my password apn settings are grey out my sim card is old

Maybe your provider is not fully supporting the Pinephone?

Is wind greece

My sim card is not 5g is 4g

Did you go to settings > mobile and switch “Mobile Data” on?
If it’s already on, switch it off, then on again.

Then check that the access point name is correct (in Advanced)

I install a fresh copy kde plasma mobile data works now.the one that comes with phone is not working

whenever your mobile data don’t work. Reboot your mobile firstly. after the reboot, if your still getting the same problem then remove your sim card and clean it properly and insert it again. that will work.

if still don’t work then setup APN. while setting up APN make sure your entering your sim card info. whichever company sim card your using. if you use other Sim card info this trick wont work. you can get all the information of SIM APN on google for free