Mobile broadband not working after wake from sleep

Hello,

my mobile broadband stopped working after returning from sleep. It worked perfectly for years. Probably some update ruined it, but I think I noticed it too late to relate it to a specific update…

So after waking from sleep if I click on the network icon in the system tray I do not even see the mobile broadband connection available. There is only wifi and ethernet.

Its a Lenovo T480s Laptop with a Fibocom pci modem.

Here is the log:

apr 11 13:07:31 lnv ModemManager[1049]: <msg> [sleep-monitor-systemd] system is about to suspend
apr 11 17:57:49 lnv ModemManager[1049]: <msg> [sleep-monitor-systemd] system is resuming
apr 11 17:57:53 lnv ModemManager[1049]: <msg> [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:1c.6/0000:3d:00.0': not supported by any plugin
apr 11 17:57:53 lnv ModemManager[1049]: <msg> [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:1f.6': not supported by any plugin
apr 11 17:57:53 lnv ModemManager[1049]: <msg> [cdc-wdm0/mbim] MBIM device is not QMI capable
apr 11 17:57:55 lnv ModemManager[1049]: <msg> [device /sys/devices/pci0000:00/0000:00:14.0/usb1/1-6] creating modem with plugin 'fibocom' and '3' ports
apr 11 17:57:55 lnv ModemManager[1049]: <msg> [base-manager] modem for device '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-6' successfully created

Only a reboot fixes it.

If I do this:

systemctl restart NetworkManager
systemctl restart ModemManager

I get to the point that I see the connection available in the network manager system tray. But when I click on the connection it gives this:

apr 11 18:15:30 lnv NetworkManager[24749]: <info> [1712852130.0631] audit: op="connection-activate" uuid="c9fd3f98-749e-4d24-baad-b82c6fafcc6b" name="Telekom" pid=1640 uid=1000 result="fail" reason="Connection 'Telekom' is not available on device ttyACM0 because profile is not compatible with device (modem is incompatible with connection: device has differing device-id than GSM profile)"

(the same happens if I right click on the network system tray and “disable networking” and then enable it again.

Im running kernel: 6.6.26-1
I tried also with these two:
6.1.85-1
5.15.154-1
But the issue is the same.

If anyone has any suggestions i would be very grateful.

You can indeed see in the first log that the id changed as the error in the second log snippet says.
My first guess will be something with the energy saving/turning devices off for sleep. You may try to tweak tlp (there is gui - tlp-ui) for example to not shutdown pci devices. Maybe if it does not turn it off it will not need to recreate it and thus change the id. Which will of course shorten the standby/sleep time.

Thanks for the tip. I used tlpui and enabled USB_EXLUDE_WWAN.

Now mobile broadband works after the computer wakes up. Will see if it affects battery usage much during sleep.

Still curious though why it would just stop working like this. This modification was not necessary before…

I few days ago I researched on how to activate my modem in a ThinkPad x13.

The [Mobile broadband modem - ArchWiki] contains info.

I had to manually add the unlock procedure for the modem - see [FCC locking]

I noted an information

Since release 1.18.4, the ModemManager daemon no longer automatically performs the FCC unlock procedure

I suggest you check the folder /etc/ModemManager/fcc-unlock.d and verify if you have a symlink matching the id for your modem.

If not locate the hardware id for the modem - either using lsusb or lspci -nn and add the relevant symlink.

2 Likes

First @Teo, I spoke too quickly. The tlpui modification did not fix it. It worked a few times when I tested it, but maybe the sleep interval was so short that it worked. It doesnt work anymore after a longer sleep.

@linux-aarhus Do you maybe know if this would be problematic only after sleep. I have nothing in fcc-unlock.d, but mobile broadband works perfectly after a reboot. From my understanding reading the documentation from version 1.18.4 completely broke wwan, not just after sleep.

But anyway, I can not find my modem anyway, my modem is usb:
2cb7:0210 Fibocom L830-EB-00 LTE WWAN Modem

And these are available:
ls /usr/share/ModemManager/fcc-unlock.available.d/
03f0:4e1d 105b:e0ab 1199 1eac 2c7c 413c:81a3
105b 105b:e0c3 1199:9079 1eac:1001 2c7c:030a 413c:81a8

Also, version 1.18.4 was released on Nov 26, 2021. But this wwan sleep problem occurred in the last month for me. And I update the OS regularly, so I must have been on a higher version for quite a while and it was working without problems…

:frowning:

I don’t - but I do think it has something to do with the fcc-unlock.

When my x13 Thinkpad (Quectel EM05-G) goes into suspend mode (systemctl suspend) it close the connection.

After wakeup the modem works again - it does not reconnect - like you may be used to with WiFi.

It looks like ModemManager - after wakeup query as qmi device