MMU Fault: ENGINE HOST0 HUBCLIENT_ESC faulted @ 0x0_00000000. Fault is of type FAULT_PDE ACCESS_TYPE_VIRT_READ

After receiving the following error my system video freezes, audio keeps working:

set 21 17:11:10 rohan kernel: NVRM: Xid (PCI:0000:01:00): 31, pid=5273, name=Renderer, Ch 00000040, intr 00000000. MMU Fault: ENGINE HOST0 HUBCLIENT_ESC faulted @ 0x0_00000000. Fault is of type FAULT_PDE ACCESS_TYPE_VIRT_READ

Relevant info:

inxi -Fxzi
System:
  Kernel: 5.19.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: KDE Plasma v: 5.25.5 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: Z390-A PRO (MS-7B98) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.D0
    date: 01/19/2021
CPU:
  Info: 6-core model: Intel Core i5-9600K bits: 64 type: MCP
    arch: Coffee Lake rev: C cache: L1: 384 KiB L2: 1.5 MiB L3: 9 MiB
  Speed (MHz): avg: 1283 high: 3700 min/max: 800/4700 cores: 1: 800 2: 800
    3: 800 4: 800 5: 3700 6: 800 bogomips: 44412
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-9.5 bus-ID: 00:02.0
  Device-2: NVIDIA GA106 [GeForce RTX 3060] vendor: eVga.com.
    driver: nvidia v: 515.65.01 arch: Ampere bus-ID: 01:00.0
  Device-3: Logitech Logitech Webcam C925e type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-9.4:9
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: nvidia gpu: i915,nvidia resolution: 2560x1440
  OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 1-9.3:7 bus-ID: 00:1f.3
  Device-2: NVIDIA GA106 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Device-3: Bose PC Desktop Controller type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Logitech Logitech Webcam C925e type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-9.4:9
  Sound Server-1: ALSA v: k5.19.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-13:5
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.67 TiB used: 313.57 GiB (11.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 1TB size: 931.51 GiB
    temp: 32.9 C
  ID-2: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
    temp: 25 C
  ID-3: /dev/sdb vendor: A-Data model: SU630 size: 447.13 GiB temp: 29 C
  ID-4: /dev/sdc vendor: Samsung model: SSD 840 EVO 500GB size: 465.76 GiB
  ID-5: /dev/sdd vendor: Kingston model: SA400S37480G size: 447.13 GiB
    temp: 30 C
Partition:
  ID-1: / size: 439.04 GiB used: 276.47 GiB (63.0%) fs: ext4 dev: /dev/sdd1
  ID-2: /boot/efi size: 96 MiB used: 37.4 MiB (38.9%) fs: vfat
    dev: /dev/sdc2
Swap:
  ID-1: swap-1 type: file size: 4 GiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
  System Temperatures: cpu: 32.0 C pch: 39.0 C mobo: N/A gpu: nvidia
    temp: 49 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 249 Uptime: 23m Memory: 31.27 GiB used: 5.44 GiB (17.4%)
  Init: systemd Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2039
  Shell: Bash v: 5.1.16 inxi: 3.3.21

This is not happening on all systems, but was discussed in the past on Nvidia developer forum

Somebody else mentioned the second part of the error you got

Since you are on a desktop PC, and from what i see you have the Monitor connected to the Nvidia GPU, why don’t you disable the iGPU from BIOS?

and make sure you don’t use the hybrid driver but video-nvidia

but on what server?
right now are both running it seems.

Care to share the content of /etc/X11/mhwd.d/nvidia.conf ?

1 Like

Xorg files

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 455.45.01

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
        Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

I have the iGPU. I tough I had disable it on the bios but since i updated the bios to use resizable bar seems I can no longer find how to disable it. Its a gigabyte z390. If anyone can give me some pointers of how to disable it I would be grateful.

What i would do, is enable early KMS. Edit the /etc/mkinitcpio.conf and make the MODULES line like this:

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

Then edit /etc/default/grub and make the GRUB_CMDLINE_LINUX line like

GRUB_CMDLINE_LINUX="nvidia-drm.modeset=1"

From terminal run:
sudo mkinitcpio -P
sudo update-grub

You could also make the Section “Device” look like this in your /etc/X11/mhwd.d/nvidia.conf

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option  "ConnectToAcpid"    "Off"
    Option "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"
EndSection

Reboot and see if this helps.
In some cases can be used also
Option "TripleBuffer" "On"
right under VendorName line and then create a file /etc/profile.d/kwin.sh with this content:

export KWIN_TRIPLE_BUFFER=1

Or you can use:

export KWIN_TRIPLE_BUFFER=1
export __GL_YIELD=USLEEP
export __GL_MaxFramesAllowed=1

I just made the modifications. When I rebuild the modules I get the following error:

==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.19-x86_64-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux57.preset: 'default'
  -> -k /boot/vmlinuz-5.7-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.7-x86_64.img
==> ERROR: '/lib/modules/5.7.19-2-MANJARO' is not a valid kernel module directory
==> Building image from preset: /etc/mkinitcpio.d/linux57.preset: 'fallback'
  -> -k /boot/vmlinuz-5.7-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.7-x86_64-fallback.img -S autodetect
==> ERROR: '/lib/modules/5.7.19-2-MANJARO' is not a valid kernel module directory

Can I just remove that file? This kernel is not even listed in the available kernels.

Of course that kernel is EOL for quite some time. Best to remove it via this command
sudo mhwd-kernel -r linux57

Error: Kernel not installed.
Currently running: 5.19.7-1-MANJARO (linux519)
The following kernels are installed in your system:
   * linux515
   * linux519

vfbsilva@rohan ~

well … then manual cleanup, but to be honest, not sure how that rogue /lib/modules/5.7 could have happen.

I don´t have a 5.7 folder it had a .old that I just removed.
For some reason I had a dangling:
/etc/mkinitcpio.d/linux57.preset
I just removed it and the error is gone.