Missing Zsh powerline prompt, Manjaro and home symbols after Plasma 6 update

image

It doesn’t seem like a common problem after the update. Any help is much appreciated.

1 Like

Your font?
The zsh theming depends on any version of a nerd font.
Make sure your profile is using one.

It is. For some percent of zsh users anyways.
Dont know the exact recipe (and I dont use zsh) but this is not the first post.

3 Likes

I think it’s not a zsh thing, but a konsole thing. I use fish and had the same problem. KDE had created a new konsole profile with an incorrect font. At first I just changed the font, but then I realized that that was not my original profile. Find it and my old font was still there.

1 Like

I wouldnt expect the KDE default to be some nerd glyph font.

But if it switched to the default profile … then how did it not switch to the default shell as well?

In whatever case … a similar situation has played out in other threads. Some in memory being a need to install a nerd font (again?).

Thanks very much. Changing the terminal (yakuake) profile font from hack to hack nerd mono fixed it. Did the font change as a result of the update? Because it was working before.

Supposedly, according to the post above, its about switching the profile.
But I am not sure thats accurate as my profile did not change. Nor did its contents.
Then again I use a custom profile with bash.

I do not know whether your settings were changed, the font path was lost, etc.

This related post on the update thread seems to believe that previously there was some sort of fall-back mechanism that no longer works. :person_shrugging:

1 Like

My guess is that this may be connected to the 2024-03-13 commit to /usr/share/konsole/Breath.profile

  [Appearance]
  ColorScheme=Breath
+ Font=Hack Nerd Font Mono,11

which was intended to address this Plasma and/or Qt issue

https://bugs.kde.org/show_bug.cgi?id=478549

Ah.
That could maybe do it if there is no functional dependency for ttf-hack-nerd, or for whatever reason it is missing, so then the setting fails.

It is a dependency of manjaro-kde-settings.

Hi Hasan,

i solved this problem.
Open konsole
Right-click in konsole.
Edit the actual profile
Then go to aparance
Change the font to “Hack Nerd Font Mono”

I had same problem, and searched for solution but didn’t find any so I just changed font from Hack to MesloLGS NF and it fixed the problem…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.