'Missing VPN plugin' error when I try to connect to my schools VPN

When I click connect I immediately get this error. I’m trying to connect to a “L2PT/IPSEC with preshared key” type VPN.

What can I do?

Install the required packages and set it up.

https://wiki.archlinux.org/index.php/Openswan_L2TP/IPsec_VPN_client_setup

If you want to use the GUI with NetworkManager install strongswan and networkmanager-strongswan . Do not install openswan . But don’t forget the xl2tpd package.

For further assistance, you should ask your Schools IT department for help.

1 Like

I installed xl2tpd, I already have networkmanager-strongswan installed. openswan is not installed, meaning, I can choose to install it from the package manager, however, it shows up in network manager somehow
image|613x500

Unfortunately I have to figure out this problem on my own. I was already told that I would only be able to connect to the VPN via Windows or MacOS.

You might want to check the files in

/usr/lib/NetworkManager/VPN/

and which file is owned by which package.

However it should not be a problem. Set your VPN connection up, configure it correctly and start it. If it doesn’t work, check the journal for errors.

journalctl -b -u NetworkManager --no-hostname --no-pager

So I checked that directory and openswan doesn’t appear there.

In any case, when I try to create strongswan vpn connection, I’m unable to put in my username/password and pre-shared key so I can’t seem to move forward. When I create the l2tp vpn connection, I can put in username/password and pre-shared key except the missing plugin problem remains.

Did you selected the correct authentication method for your connection? You need to ask again your School IT Staff for this information. Or simply try all.

Depending on the authentication method, different fields are active. You can also click on the icon in some fields to open a file chooser or select different types (password storing).

L2PT/IPSEC/IKE is one of the more complex VPN methods. There are many different implementations, sometimes with very different ideas of what a vpn client has to do. There is no real standard for this type of VPN. Even if you can get everything right, there is no guarantee that you can successfully connect. Specially without support from the VPN Server admin.

Hmmm I don’t see L2PT/IPSEC/IKE as a VPN connection type that I can create.

Unfortunately, the only VPN connection type option that I have found that allows me to input a pre-shared key AND username/password is Layer 2 Tunneling Protocol (L2TP) which is the one that gives me the missing plugin error.

Before I ask for help, I have to eliminate my own system as being the problem. Why am I getting the plugin error? The problem is on my end it seems to me.

This is nothing you can select. I used it as a general description of this VPN type form a standard/protocol view.

So check the journal for a more descriptive error. However the only NetworkManager Plugin that reliable works for this VPN type is the strongswan NetworkManager plugin. I don’t know what packages you installed to get this many entries in the NM connection editor window. You should clean up your installed packages related to VPNs and NetworkManager.

You need to select the correct type, and I give you one hint, it is not “prepared key” if you need to use a username, password and prepared key. Sometimes the prepared key is the username, but this is something you need to ask your School IT department about.

This will be my last post in this thread. Good luck.

1 Like

Your guidance is appreciated. Thanks!

I’m still getting the ‘Missing VPN plugin’ error when I try to connect to my schools VPN.

Anyone have any ideas?

I had the same issue, try

yay -S xl2tpd strongswan networkmanager-l2tp

According to https://gist.github.com/pastleo/aa3a9524664864c505d637b771d079c9

@ tengl I installed networkmanager-l2tp, the other 2 were already installed. So there is some progress, now I’m getting a different error: Starting the service providing the VPN connection failed.
image
I selected Layer 2 Tunneling Protocol (L2TP); Compatible with L2TP VPN servers when I created this connection

I am a bit of a n00b when it comes to these things so I thought I should also post the instructions that I was given

Connecting to VPN from Windows

Tap Start > type in VPN and select “Change Virtual Private Networks (VPN)
Choose Add VPN connection
For the VPN Type select: Windows (built-in)
Connection Name: ARTS VPN (you can call it whatever you like)
Server Name: ***
VPN Type select “L2PT/IPSEC with preshared key”
Under the field below for Preshared key use: ***
Type in your username and password in the fields below that

Connecting to VPN from a Mac

Open System Preferences > Network
Click the plus “+” button at the bottom-left
Interface: VPN
VPN Type: L2TP over IPSec
Service Name: ARTS VPN (you can call it whatever you like)
Server Address: ***
Account Name: arts\<username> (e.g. arts\jsmith)
Click “Authentication Settings…”
Under “User Authentication”, enter your ARTS password (the same one you use on the lab computers)
Under “Machine Authentication”, enter *** in the “Shared Secret” field
Click “Ok” > "Apply" > "Connect"
You can check the box to "Show VPN status in menu bar" for easier access

@bassamanator Sorry for late reply, but I’m a Linux n00b and not an expert in VPN. I got my VPN to work, basically with the same settings as yours.

However, today I’m having the exact same problem as you do. It worked on Friday but not today. Will get back to you.

I’m a Linux n00b myself; we’re in the same boat :slight_smile:

Your input is appreciated!

So I thought that instead of using the domain name of the gateway, I would use the IP address. Now the VPN connection attempt doesn’t immediately fail, it takes several seconds and then it says The service providing the VPN connection was stopped, followed by another error message VPN connection to ‘name’ failed.

This was happening with me when I was work from home and try to connect my office vpn and sometime it showed me an error but not always. After some try it worked properly but I contacted with IT team and they were resolved it. If you constantly facing this issue then you should get a dedicated IP and discuss with IT to allow this IP to access School data.