Missing spell checker Libre Office

Hi There,

Libre Office which installed by default with Manjaro is missing its spell checker. Does anyone know how to add it? Looked in AUR but found nothing, Libre Office site did not offer much and a general search did suggest this is not uncommon but could not find any Arch specific command lines to add it to Libre.

Any insights appreciated.

You need to install hunspell dictionaries for it. Some of them might only be found in the AUR.

1 Like

In Libreoffice Writer, go to the Spelling menu option (I believe it is under the Tools menu), and at the bottom, you’ll find an option to add additional dictionaries. As mentioned previously, you’ll need at least one dictionary to have the spell checker work properly. My guess is that being available in many languages, the folks developing the installer figured it would be easier to leave it up to the user to select his/her desired language. I found this a bit tricky to troubleshoot too, but adding the dictionary worked for me.

Already installed but the spell checker is not working.

Not finding anything much under tools. I have a dual boot with Windows, I’ll check it using MS Office for now and look at alternatives to Libre in linux.

Thanks for the advice nonetheless.

  1. Perhaps you accidentally disabled Automatic Spell Checking?
  2. There are more options available that you may want to enable in Tools → Options → Language Settings → Writing Aids
  3. You may find LanguageTool extension useful.

Could be that your language’s dictionary is not supported properly, ie installed automatically.

Look at the bottom of your LibreOffice screen, is your preferred language showing? Is it not US or UK? If not, go to the Package Manager search for ‘hunspell’ you may see a long list of dictionaries for different languages but install the one for you.

After installing your dictionary a restart of LibreOffice should fix your problem.

:slight_smile:

1 Like

Can you confirm what was installed:

pacman -Ss 'hunspell' | grep install

If english:

extra/hunspell 1.7.0-3 [installed]
extra/hunspell-en_us 2020.12.07-4 [installed]

A side note.

I recently installed Manjaro that was listed in the last Release Announcement on a VM and it did not install LO by default. The only package with the string “office” that was installed by default was onlyoffice-desktopeditors (grep -i office /desktopfs-pkgs.txt). It might have been the default, or the install asked (which it did when I originally installed some time ago), in the past. If this is a new install, make sure you have the latest ISO.

I found this troublesome to get working too, it seems the dictionary is available, but it’s not correct unless it shows a green tick.
The method I used was Tools > Spelling > Options > 'get more ditionaries online' & installed the English one.
When correctly configured it will show a :white_check_mark: Green Tick in the drop down in Tools > Options > Langs (default) and Tools > Spelling

Screenshot from 2022-04-11 11-06-55

Whilst I can’t remember whether I had to do anything special on my Manjaro install, I seem to remember getting this working on a different arch-based distro a short while back by following the instructions on the Arch Wiki - if you’ve not investigated this, it’s worth working your way through the instructions there for getting hunspell installed and the dictionary for your particular language activated - LibreOffice - ArchWiki

afik for any LO installation you need a corresponding language pack as well.
In my case eg. for libreoffice-fresh the libreoffice-fresh-de

These are good points @Riquez.

  • Tools > Spelling

    • Confirm the “Text Language”
      Mine looks different. I’m using a light theme in XFCE, and the control is a simple drop-down list. I installed from Manjaro repository hunspell-en_us.
  • Tools > Options > Language Settings > Writing Aids

    • Under “Available Language Modules”, the listbox contains “Hunspell SpellChecker” and it is preceded by a checkmark. The name will vary based on what was installed, just make sure it is checked.

Searched the forum and found: