Missing sound profiles in KDE audio settings

For some reason I’m not seeing analog stereo duplex or analog stereo output in the list of sound profiles:

I can set it with pacmd set-card-profile which gives me sound but they still don’t appear in the audio settings and the profile field is blank. I also had to change the output device to headphones in AlsaMixer but that might be an unrelated problem. Is there some way I can fix this?

The profiles show up in PulseAudio volume control but it shows (unavailable) after the name. If I select analog stereo duplex the sound works but as soon as I reboot my PC it resets again. How can I get it to remember the profile after a reboot?

You need hdajackretask which is in the alsa-tools package, so:

pamac install alsa-tools

In that screen you need to:

  • Select the correct codec
  • Click Show unconnected pins

and then it becomes fuzzy as I have no system information on your hardware but basically you need to override one or more of the unconnected pins to the features you want.

  • Once you’ve done all of the needed overrides, you need to click Apply now and test.
  • If that would give you an error message, you need to:
    • Click Boot override
    • Reboot
    • Test

Repeat until you get what you want.


1 Like

Wow that fixed everything. I can even see the correct audio profiles in the settings now. Thank you !!

1 Like

You should really thank @nikgnomic who taught me this trick and who’s a genius when it comes to audio…


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.