Missing packages for installing Maui-Shell

I want to install the Maui-Shell on the latest Manjaro KDE Plasma 22.02 for Radxa Zero.
This is the tutorial I use:

The Mauikit and the Mauikit-FileBrowsing compiled and installed fine. But the Maui-Shell itself throws a error when compiling it.

CMake Error at /usr/share/cmake/Mudules/FindPackageHandleStandardArgs.cmake:238 (message):
  Could NOT find KF5 (missing: DocTools Init) (found version "5.91.0")
Call Stack ( most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/ECM/find-modules/FindKF5.cmake:93 (find_package_handle_standard_args)
  startcask/CMakeLists.txt:1 (find_package)

Does it work with that version of system or not?
The guys from Nitrux wrote to me that I am missing some packages in Manjaro provide kdoctools and kinit.
Does anyone tried the same and knows this issue?

You will have to install the missing dependencies - as instructed.

And where can I find them?

From the repos - they shouldn’t be hard to locate as you have been given the package names

Ah yes I found it. I don’t get it to search with KF5.
Now it compiles but the shell cancels after a few seconds.

org.kde.plasma.pulseaudio: No object for name "alsa_output.platform-sound.pro-output-0.monitor"

I don’t think this is a Manjaro issue. Am I right?

The message you get is a matter of system configuration.

This is a guess - It could be because the system is using pipewire not pulseaudio and the shell looks another dbus connection.

Ah ok. Do you know where I can change this configuration?

I don’t know - I am not a KDE specialist - nor a audio specialist - but from the bits and pieces I picked up - KDE Plasma has shifted towards using pipewire - presumably a successor to pulseaudio - and that pulseaudio and pipewire are mutually exclusive.

I am a coder writing business software and when it comes to audio I use it very little and when I use it I know where to select the correct input and the correct output (headset) - so I am of very little help in that regard.

@Oli Instead of building it from source from github you should install maui-shell package which in available for ARM in kde-unstable repos. You can switch to ARM and check here Manjaro - Branch Compare. To enable it, add the following lines to /etc/pacman.conf:

[kde-unstable] Include = /etc/pacman.d/mirrorlist

The kde-unstable entry should be first in the list of repositories (i.e. , above the [core] entry). Also if you are using this repo it is advisable to switch to manjaro unstable branch. See Switching Branches - Manjaro.

Ah thank you. I switched the repository.
Can I download the package from unstable repo using git clone --depth 1 --branch master https://invent.kde.org/maui/mauikit.git or do I have to execute something different?

Sync the newly added repository and install the package:

sudo pacman -Sy maui-shell

It doesn’t found it. That’s strange. Can I install it a different way?

Can you share the contents of /etc/pacman.conf?

The repo exist on all branches - I would think that it should only be used from unstable branch.

# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg      = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system manjaro-keyring manjaro-arm-keyring archlinux-keyring archlinuxarm-keyring
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = aarch64

#IgnorePkg   =
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinuxarm manjaro-arm`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Edit your pacman.conf and just above the


You insert two similiar lines

But only do so on unstable branch. I suspect this repo will require the latests system libraries as well and if you may get into trouble if you don’t have the latest.

Include = /etc/pacman.d/mirrorlist
sudo pacman-mirrors -aS unstable && sudo pacman -Syyu

Ok I get it. I can install the maui-shell. But its the same result. When I start cask the console shows the same output.